summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-07 10:19:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-07 10:47:15 +0200
commit3560d2bc3592bffb6e127913b71dba8fa94760e4 (patch)
treefdcb2c97c9e1410c04ef3ad1cce68c8f3f8cda2b /dev-python/sentry-sdk
parentdev-python/django: Bump to 3.2.2 (diff)
downloadgentoo-3560d2bc3592bffb6e127913b71dba8fa94760e4.tar.gz
gentoo-3560d2bc3592bffb6e127913b71dba8fa94760e4.tar.bz2
gentoo-3560d2bc3592bffb6e127913b71dba8fa94760e4.zip
dev-python/sentry-sdk: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 5112c6e965d1..d5e140d98be9 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1 +1,2 @@
DIST sentry-sdk-1.0.0.tar.gz 213707 BLAKE2B 9fa3dfac7d82c9e2c81be6f4edafbc27ab19a2a96876885dabe72d2dbd6cf392b80e453c640affb94d84f35b227b12d56927bec88e01a0ebfdcf8a466470a909 SHA512 e91ede3e5e31c2acba7094bd5c6a95280aa8367b1fcd524fc9b100d2a3a253efec1ed3d9c72465f5b2ef5276c834906d622b84e1650b65d2032f4acaf2fd1ab8
+DIST sentry-sdk-1.1.0.tar.gz 215946 BLAKE2B 486f32430a03d42c73814195ef16ec4efc71512faca197d8020fad7b3d1e7350ec619ef453075bc4fc4e0e454f3aa6eda41ec29b88af19d75b5f6a10273db325 SHA512 500d0d3add4bf8e74f2e34d6c00491f4bbd45a2226cc0ee93ca0f63f5ae5aea61be6730f845d50e10909c9ede6918ec6cfb90e5ebe80b753dd634ac9a9238061
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild
new file mode 100644
index 000000000000..1a90236e8d17
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.1.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/requests/test_requests.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # hangs
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest ${deselect[@]/#/--deselect }
+}