summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 01:06:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 01:11:57 +0100
commit576de1c27007df97308be2f8a2d8627ee35a3445 (patch)
tree31867692dfd51a1f3a26ba288f96e5b1a232d487 /dev-python/sentry-sdk
parentdev-python/aniso8601: Bump to 9.0.0 (diff)
downloadgentoo-576de1c27007df97308be2f8a2d8627ee35a3445.tar.gz
gentoo-576de1c27007df97308be2f8a2d8627ee35a3445.tar.bz2
gentoo-576de1c27007df97308be2f8a2d8627ee35a3445.zip
dev-python/sentry-sdk: Bump to 0.20.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 864352ceb6c9..22d48d58ecee 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,4 @@
DIST sentry-sdk-0.19.5.tar.gz 206164 BLAKE2B 9d7ce2a64fcb511c659188dc18bc4af18052c0f12ff5d31848f341ef20cbc6c9cf1102d17e6e8d8b741eb8000f94978f840f3ec66b43367820e0ccce97b1fd1b SHA512 082ace137656e8cc8317e70cf4fe9823ccf8cc3ed7b54af059990cede72179924a36896a31a806de4adbbf3bd66e54d5385eb630c047b929583e32c39ed69d61
DIST sentry-sdk-0.20.1.tar.gz 210762 BLAKE2B 64ff322667374c914aa00a80ffa5eca2d92ec0965bc6bf7bdc65cf89e75a3cd5f5db32cd7e442caae515348b1f7948209e9810729f4fbc913730337f06444b73 SHA512 cd7871bd3da31340752477058fcf788401910a4e0b4ac38d53beafbedcdfe62b3216d6d2bcf2d1998e8c3e02886da76f6a8aa2809ba1e473421f96257890e75c
DIST sentry-sdk-0.20.2.tar.gz 210799 BLAKE2B 7a7b4350b664ee6947fcba64aa07a4e9f8ec274de7433d64acce55d490ea91f97a19ab7116e7af3109f806c91261f50127c72627bca1bbf76c43ad4ac89455e2 SHA512 3fb2d4ae960c86582e778afb0fdf12f3ff9103a83fb12a6c920bd6fe1e210842d29d2cfba12c254199a491a5b42288df0c388b37a8709fdabc9e6e9687b178c1
+DIST sentry-sdk-0.20.3.tar.gz 212130 BLAKE2B 48084039c493ca2903f56426913ea8f8f0480b759157270fe6ea4dfae72f9478d8566f8a86f6f863c06adb01379e980d5f873372f401a8d3f255f62f8a149b45 SHA512 0392fcf0e718f7d06200fa44fedf1aac46a2f61d11a8252ca339652d5385a377545128c1c4b9e31e1e1a8c8c9a8c57ded569b829312a748d84ad98696a897944
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild
new file mode 100644
index 000000000000..7b31e702fe53
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-0.20.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ tests/integrations/stdlib/test_httplib.py
+ tests/integrations/requests/test_requests.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # hangs
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ pytest -vv ${deselect[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
+}