summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-13 13:39:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-13 14:07:19 +0200
commit89f056729b58425e06fdf90db491d07e983887ef (patch)
tree15d9bca44568b02aee7cd213d8e5b7578469a191 /dev-python/sentry-sdk
parentdev-python/xlsxwriter: Bump to 1.3.7 (diff)
downloadgentoo-89f056729b58425e06fdf90db491d07e983887ef.tar.gz
gentoo-89f056729b58425e06fdf90db491d07e983887ef.tar.bz2
gentoo-89f056729b58425e06fdf90db491d07e983887ef.zip
dev-python/sentry-sdk: Bump to 0.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.19.0.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 7f35a57c39e1..0fabe228d5a4 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -3,3 +3,4 @@ DIST sentry-sdk-0.17.6.tar.gz 183157 BLAKE2B ea0f6af54c31abc785274fc75238a02b8c9
DIST sentry-sdk-0.17.7.tar.gz 184034 BLAKE2B de71b2e270594abe2e16d7e2fb9db3028e3c2abd4539269562e8786e6d937352153da21d6366d5e0384e3de1dbd6fbabe3d5060a6f0f9953bd260fbd865c893d SHA512 2360321ec0231ba76c968ff4e6dc78d42a48106aa6aade73a1c1194f9406fbafea3b533994da42027b3479302756ed3ec6e44ce551cb01ce60397939beaeb6d4
DIST sentry-sdk-0.17.8.tar.gz 184271 BLAKE2B d34f881632e66d5db5cad0c6979de6c3c6205119af30b34996122ff7aff1ed7c3dd0c1603e57163f5d72c8525921f9af7c3e1c729adb14b43dbcee0aa4bd9fc5 SHA512 84ae0ca888457ed833b416320c45040e522a656d7c3ca0d64639f179e7be3237f53cfe4827e986a50d37bd7b61da765ed8c00ea663d478874cc47623ccf47a51
DIST sentry-sdk-0.18.0.tar.gz 186389 BLAKE2B f531d68a1244c34d267cb332263c996afad31f7f72710b868e14850f06de6225a11fc37dca9ff820fc14d2f1b29919cfb10f59b7dc4449c0734458c6bd1b9816 SHA512 4c78418392668b1e061f0d6b88d3cc3511db138a99b08df50d2e610a7d8a5528ad83943ef1cfda8d508cb3b52f511f872ac87439460254a6b28348c9bb92406c
+DIST sentry-sdk-0.19.0.tar.gz 186477 BLAKE2B 67e538526d39f814827f2d53ca2b8f59f1a3f13e3a0622e5a1ae8870c04d320dadac2c93e8afa786b47feb9295e6e50beb831112448ab89a1eaae750895378df SHA512 5bf598af1fd7a565fd20f38a3e4961136fc2d102cdb9810cb43802e696897669ae679d82dec14cef5cdf0d3ee9dc7a3def39457b733b1018dd91f82066e2422f
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.19.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.19.0.ebuild
new file mode 100644
index 000000000000..1e52e8d55106
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-0.19.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://getsentry.com https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ <dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/aiocontextvars[${PYTHON_USEDEP}]
+ dev-python/contextvars[${PYTHON_USEDEP}]
+ ' python3_6)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ --deselect tests/integrations/stdlib/test_httplib.py
+ --deselect tests/integrations/requests/test_requests.py
+ # wtf is it supposed to do?!
+ --deselect tests/integrations/gcp/test_gcp.py
+ # fails on py3.6, hangs on py3.7+
+ --deselect
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ --deselect
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ --deselect
+ tests/test_client.py::test_databag_depth_stripping
+ --deselect
+ tests/test_client.py::test_databag_string_stripping
+ --deselect
+ tests/test_client.py::test_databag_breadth_stripping
+ # test_filename: apparently unhappy about pytest being called pytest
+ --deselect 'tests/utils/test_general.py::test_filename'
+ # test_circular_references: apparently fragile
+ --deselect
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ )
+ [[ ${EPYTHON} == python3.6 ]] && deselect+=(
+ # broken with contextvars on py3.6
+ --deselect
+ 'tests/utils/test_contextvars.py::test_leaks[greenlet]'
+ --deselect
+ 'tests/test_transport.py::test_transport_works[greenlet'
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}