summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 20:41:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 21:46:18 +0100
commit8c64bd1a487fcdd94d393979487340029aa36f0e (patch)
tree77d13341a0af9e40110f7e0ad315b7ccd276e923 /dev-python/sentry-sdk
parentdev-python/mako: Bump to 1.1.6 (diff)
downloadgentoo-8c64bd1a487fcdd94d393979487340029aa36f0e.tar.gz
gentoo-8c64bd1a487fcdd94d393979487340029aa36f0e.tar.bz2
gentoo-8c64bd1a487fcdd94d393979487340029aa36f0e.zip
dev-python/sentry-sdk: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 8f4c650d3a1e..8d33acf62427 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1 +1,2 @@
DIST sentry-sdk-1.4.3.tar.gz 231054 BLAKE2B 39509b3f7b12e773e23881772cf2d3445374181f7bd23b3a7abe3cbdae012b03b43bcd4ce811a40cd2c7916cae378698ea5a53909b2f679d8b3f3598e675719e SHA512 bd5a1b75a437d28348f980cad0bad30cbcd2872fc9678e50d69bca73e0a08a8e663f0fd54607174122072dafad6055acc73db34c6ca92ec9d00efed41e5c1c97
+DIST sentry-sdk-1.5.0.tar.gz 233213 BLAKE2B f3debc106d1009eff09ae2acb1073d3a8244e39a746e063e869ee158a47a6542f485e8030515b1c633ca978950a4543c3a0ea4e2b1fb4408e478fde2d92bf33b SHA512 7cd9706749712ab55137b0eb05d100c42b9d644ffe76773ff97fc738ad3c1525b4381f8ea9168d8a87ee9932642837b542695bbe96bc2662a246a41368fd40d4
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild
new file mode 100644
index 000000000000..ffb7c607d135
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.5.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest
+}