summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-21 20:16:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-21 21:11:44 +0200
commitaf2a6c687da95db43608d76b15476871b25a3c5f (patch)
tree26ba8aa0d90073c7670c3ceb8af14483ed022c3e /dev-python/sentry-sdk
parentdev-python/huawei-lte-api: Bump to 1.5.2 (diff)
downloadgentoo-af2a6c687da95db43608d76b15476871b25a3c5f.tar.gz
gentoo-af2a6c687da95db43608d76b15476871b25a3c5f.tar.bz2
gentoo-af2a6c687da95db43608d76b15476871b25a3c5f.zip
dev-python/sentry-sdk: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.4.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index afbe92eee441..23a013759092 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1 +1,2 @@
DIST sentry-sdk-1.3.1.tar.gz 219705 BLAKE2B 3fc8f81a5f762f400c70ae1c83ab46e97ec4641a61b86dc5b5a2cdbc22395b60fd53cef2d3d2dbfaaceb2d0bd32b842344fcaab898900b7dee2bd34ae3660f8b SHA512 60d819880b3d5316cad1ae4d236820f410c22c75c97d54d681f43ac6dfb503d3c5817314dd2db37107902b4e28d4f981ade200413388ecaf534135829723ef38
+DIST sentry-sdk-1.4.0.tar.gz 230870 BLAKE2B 8cad1f0046219b60af982d3a01ae67aa1b018c4c8815c2adae834beeea6015057791abff6e1213a4a5902fe62e56f232dcb0cb355927c2f986751145dc633962 SHA512 b1f3021b4a67c2c4e13109ec3e189d1e133f07ecad18bc3e0ebd7b99e90b53aa83cac2cc567b8b47763892a9e06e1795aca497f146cbaae15952c880f9c160cd
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.4.0.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.4.0.ebuild
new file mode 100644
index 000000000000..d0881dad90d7
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # hangs
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest ${deselect[@]/#/--deselect }
+}