summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 23:41:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:52 -0500
commit51f5a511d7418b6c67d8f56abcebea17aef47fdd (patch)
treef727a2416bc8e54cca6a40dffb7313fe1b948fc4 /dev-python/setproctitle
parentdev-python/ldappool: 2.4.1 bump (diff)
downloadgentoo-51f5a511d7418b6c67d8f56abcebea17aef47fdd.tar.gz
gentoo-51f5a511d7418b6c67d8f56abcebea17aef47fdd.tar.bz2
gentoo-51f5a511d7418b6c67d8f56abcebea17aef47fdd.zip
dev-python/setproctitle: 1.1.10-r1 for py37 support
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
new file mode 100644
index 000000000000..1de283ce2daa
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.10-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# pypy doesn't get started in test run. Still required by www-servers/gunicorn
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# Required for re-write of test suite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ # Make a nice html file
+ rst2html.py README.rst > README.html
+ # The README.rst will be duplicated in src_install
+ rm README.rst || die
+}
+
+python_test() {
+ # The suite via the Makefile appears to not cater to pypy
+ [[ ${EPYTHON} =~ pypy ]] && return
+
+ # prepare embedded executable
+ emake \
+ CC="$(tc-getCC)" \
+ PYINC="$(python_get_CFLAGS)" \
+ PYLIB="$(python_get_LIBS)" \
+ check
+}