summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-12 09:48:11 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-12 09:56:45 +0100
commitfdf6b61a56b7e7c677b26ba14926a2cf85420d8b (patch)
treed5ac487f4981b392ac8f49005a192d0737e76dbf /dev-python/setproctitle
parentdev-libs/btparser: Use eclass functions to obtain build variables (diff)
downloadgentoo-fdf6b61a56b7e7c677b26ba14926a2cf85420d8b.tar.gz
gentoo-fdf6b61a56b7e7c677b26ba14926a2cf85420d8b.tar.bz2
gentoo-fdf6b61a56b7e7c677b26ba14926a2cf85420d8b.zip
dev-python/setproctitle: Use eclass functions to obtain build variables
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.8.ebuild17
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.9.ebuild17
2 files changed, 22 insertions, 12 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.8.ebuild b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
index 0b853ee7ada6..b028123889dd 100644
--- a/dev-python/setproctitle/setproctitle-1.1.8.ebuild
+++ b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
@@ -4,6 +4,7 @@
EAPI=5
+# pypy doesn't get started in test run. Still required by www-servers/gunicorn
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
inherit distutils-r1 toolchain-funcs
@@ -18,8 +19,6 @@ KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-
IUSE="test"
RDEPEND=""
-# on <py2.7 the test suite uses SkipTest from nose,
-# so we need to run it using nose.
DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
DOCS=( HISTORY.rst README.rst )
@@ -42,10 +41,18 @@ python_test() {
cd "${BUILD_DIR}" || die
+ if [[ ${EPYTHON} =~ pypy ]]; then
+ # The suite via the Makefile appears to not cater to pypy
+ return
+ else
+ CPPFLAGS="${CPPFLAGS} $(python_get_CFLAGS)"
+ LDLIBS="$(python_get_LIBS)"
+ fi
+
# prepare embedded executable
emake tests/pyrun CC="$(tc-getCC)" \
- CPPFLAGS="${CPPFLAGS} $(python-config --cflags)" \
- LDLIBS="${LDLIBS} $(python-config --libs)"
+ CPPFLAGS="${CPPFLAGS}" \
+ LDLIBS="${LDLIBS}"
- nosetests || die "Tests fail with ${EPYTHON}"
+ nosetests --verbose || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/setproctitle/setproctitle-1.1.9.ebuild b/dev-python/setproctitle/setproctitle-1.1.9.ebuild
index c86c655d223d..e09507e56968 100644
--- a/dev-python/setproctitle/setproctitle-1.1.9.ebuild
+++ b/dev-python/setproctitle/setproctitle-1.1.9.ebuild
@@ -15,12 +15,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos \
- ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RDEPEND=""
-
DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
# Required for re-write of test suite
@@ -34,8 +32,13 @@ python_compile_all() {
}
python_test() {
- # The suite via the Makefile appears to not cater to pypy
- if [[ "${EPYTHON}" != pypy ]]; then
- emake check
- fi
+ # The suite via the Makefile appears to not cater to pypy
+ [[ ${EPYTHON} =~ pypy ]] && return
+
+ # prepare embedded executable
+ emake \
+ CC="$(tc-getCC)" \
+ PYINC="$(python_get_CFLAGS)" \
+ PYLIB="$(python_get_LIBS)" \
+ check
}