summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-12 11:12:22 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-12 13:06:27 -0400
commit68685ee1aa24ad7636ec26b941abfb939ac35200 (patch)
tree10a3ad8bfd8102ddb63bd71268908988ca55855a /dev-python/setuptools/setuptools-9999.ebuild
parentdev-perl/digest-bubblebabble: Removed, gone to dev-perl/Digest-BubbleBabble (diff)
downloadgentoo-68685ee1aa24ad7636ec26b941abfb939ac35200.tar.gz
gentoo-68685ee1aa24ad7636ec26b941abfb939ac35200.tar.bz2
gentoo-68685ee1aa24ad7636ec26b941abfb939ac35200.zip
dev-python/setuptools: version bump to 27.1.2
Diffstat (limited to 'dev-python/setuptools/setuptools-9999.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-9999.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/setuptools/setuptools-9999.ebuild b/dev-python/setuptools/setuptools-9999.ebuild
index a224987f7b53..136c3f53f0bb 100644
--- a/dev-python/setuptools/setuptools-9999.ebuild
+++ b/dev-python/setuptools/setuptools-9999.ebuild
@@ -3,19 +3,23 @@
# $Id$
EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+inherit distutils-r1
-inherit distutils-r1 mercurial
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
DESCRIPTION="Collection of extensions to Distutils"
-HOMEPAGE="https://pypi.python.org/pypi/setuptools"
-SRC_URI=""
-EHG_REPO_URI="https://bitbucket.org/pypa/setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.python.org/pypi/setuptools"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RDEPEND=""
@@ -38,7 +42,12 @@ DISTUTILS_IN_SOURCE_BUILD=1
DOCS=( README.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
python_prepare_all() {
-# rm -r ./pkg_resources/_vendor || die
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # rm -r ./pkg_resources/_vendor || die
# disable tests requiring a network connection
rm setuptools/tests/test_packageindex.py || die