summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-18 15:04:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-18 15:23:14 +0200
commit166c3d34e99c7d4ff9d889c0a049f9a50875971f (patch)
tree542b77859da49d3048568edfe5d7a304064f02e0 /dev-python/setuptools
parentdev-python/requests-mock: Add tdep on dev-python/pytest (diff)
downloadgentoo-166c3d34e99c7d4ff9d889c0a049f9a50875971f.tar.gz
gentoo-166c3d34e99c7d4ff9d889c0a049f9a50875971f.tar.bz2
gentoo-166c3d34e99c7d4ff9d889c0a049f9a50875971f.zip
dev-python/setuptools: Silence py2 warning
The py2 warning is not very useful for us and its verbosity breaks other packages. Closes: https://bugs.gentoo.org/723680 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/setuptools-46.4.0-r1.ebuild (renamed from dev-python/setuptools/setuptools-46.4.0.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/setuptools/setuptools-46.4.0.ebuild b/dev-python/setuptools/setuptools-46.4.0-r1.ebuild
index 12991147d665..fff9aec03927 100644
--- a/dev-python/setuptools/setuptools-46.4.0.ebuild
+++ b/dev-python/setuptools/setuptools-46.4.0-r1.ebuild
@@ -41,6 +41,11 @@ DISTUTILS_IN_SOURCE_BUILD=1
DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
python_prepare_all() {
+ # silence the py2 warning that is awfully verbose and breaks some
+ # packages by adding unexpected output
+ # (also, we know!)
+ sed -i -e '/py2_warn/d' pkg_resources/__init__.py || die
+
# disable tests requiring a network connection
rm setuptools/tests/test_packageindex.py || die