summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-03 22:49:13 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-03 22:49:13 +0200
commit791bf5826ccc3aae78d1873c055ebb925f4353e8 (patch)
tree04cd381ee12b6a51da82cf412a40d4b45376d127 /dev-python/setuptools
parentdev-python/pylint: Version bump to 1.5.5 (diff)
downloadgentoo-791bf5826ccc3aae78d1873c055ebb925f4353e8.tar.gz
gentoo-791bf5826ccc3aae78d1873c055ebb925f4353e8.tar.bz2
gentoo-791bf5826ccc3aae78d1873c055ebb925f4353e8.zip
dev-python/setuptools: Version bump to 20.6.7
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-20.6.7.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index ec1c92b4aee7..e7370a4c3a2a 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -12,3 +12,4 @@ DIST setuptools-20.0.tar.gz 641692 SHA256 a6f7b295f399fed3de918c4bea9e2053a5fbd9
DIST setuptools-20.1.1.tar.gz 641777 SHA256 2663ce0b0e742ee27c3a06b2da14563e4f6f713eaf5509b932a31793f9dea9a3 SHA512 72da2f5a4e07c14975b3e13246264cb4b9eb52bd6da22fce0ef0f0bb8d902249067e6c23bf263cda45de92a0cdb794f454dff95e52505045e03c7a6ab28cb2ca WHIRLPOOL d2f3f0fd31f4b7d35178c14cd411dae0b011c3f9efd8a7dea4cde24bee1e462758a9662e989ddea7777b111c6162e7d035cf924517e7e6bdcab0b3277d7765e1
DIST setuptools-20.2.2.tar.gz 676284 SHA256 24fcfc15364a9fe09a220f37d2dcedc849795e3de3e4b393ee988e66a9cbd85a SHA512 e74004e5755e1abd9e6efb94887c9124a36e67651e6e626424e96575cf8e84a258d48ee6fa8f0389f15de3bddcbcb0a690810dd46c358f85659ad6f20f905a2d WHIRLPOOL 3f3b7c3c916d88fb6fc53e0b348605fbaa0463abf44a164641fb8eba0050bd1513af971874b9415b1b4939b49504e4378d7142c04ba8300fb5e468cbdb35a144
DIST setuptools-20.3.1.tar.gz 676378 SHA256 a1b3f74a1dc7c81368f2bc28a34366cfa6ffe80cdee1451261aabfba1ae1f4a8 SHA512 694258290c27cc2edbc83958de5ea4d8ebd3f96a3708012260438188fc4fd3b30a427ef87bfd418a188a74077acefb9d6e50bcf189c98a9380277f0087cce83b WHIRLPOOL 3119a672d4655f49d9dba0ad65230a0991584c4904c6eb6f3e6d15e09b3689f7cdeeb1e9198472830e02a6756c9cf92dc51292e77eb8f725f5a6f748a80fabda
+DIST setuptools-20.6.7.tar.gz 675428 SHA256 d20152ee6337323d3b6d95cd733fb719d6b4f3fbc40f61f7a48e5a1bb96478b2 SHA512 91a212b5007f9fdfacb4341e06dc0355c5c29897eb8ea407dd4864091f845ba1417bb0d33b5ed6897869d0233e2d0ec6548898d3dbe9eda23f751829bd51a104 WHIRLPOOL 553a1579991e9478b8eb8dd2f4ab042cd5286c1233f325d1fe1c08092035c6346aa454c03307359d7dd562174133247200c3a5424f5fc24f4718db0ad80d84fc
diff --git a/dev-python/setuptools/setuptools-20.6.7.ebuild b/dev-python/setuptools/setuptools-20.6.7.ebuild
new file mode 100644
index 000000000000..6d462a6c8be2
--- /dev/null
+++ b/dev-python/setuptools/setuptools-20.6.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+# >=dev-python/packaging-16.4[${PYTHON_USEDEP}]
+# >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+# "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+# >=dev-python/pyparsing-2.0.6[${PYTHON_USEDEP}]
+PDEPEND="
+ >=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+# rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}