summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-09 09:25:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-09 09:53:09 +0200
commit8ea37965748bff7a728d6a9959ba19f54983e4c6 (patch)
treebb3b1dcca6c3af6603709b88e1b1ee1603581c24 /dev-python/setuptools
parentdev-db/pg_activity: version bump to 2.1.4 - remove old (diff)
downloadgentoo-8ea37965748bff7a728d6a9959ba19f54983e4c6.tar.gz
gentoo-8ea37965748bff7a728d6a9959ba19f54983e4c6.tar.bz2
gentoo-8ea37965748bff7a728d6a9959ba19f54983e4c6.zip
dev-python/setuptools: Bump to 56.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-56.0.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index f16d4c2f2710..61c4ebedbe17 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -2,3 +2,4 @@ DIST setuptools-53.1.0.tar.gz 2051159 BLAKE2B f4148df45f5c62acd6acae833619dcae50
DIST setuptools-54.1.1.tar.gz 2053415 BLAKE2B 59d60e9be5a184e34e8c9e1ccb477eae538836c8fac4862f3365e1abe8beec6cc85490918d413b29831c4d3738ca19cd84ac4a9d30178e45e42c652a0ade5fac SHA512 d2ab5445a9b4de5b5fae8aab6a47131ad41a011fa23fb1e6c07a599bcb27a8f89ea3c5ea9939577d6286bf3f8e2edf0334816ae1a507dba09c46435d063c3379
DIST setuptools-54.1.2.tar.gz 2053508 BLAKE2B 23958ab6bc8ac5681fb4a86217b893f5389be1afc9e71f77a3aaaca469e3f86117e55f9df8f864ae56059ef6aef054a6a5ce8d6670a5ce266de6322b820e68d7 SHA512 b6efe6e92227704a95d4d4a31d033df6df96a430d7e51cb7df80203af56d8f8f64c95deaf194c7cfbfd2111f5bc02be45db2c0383c3209c898c1858821eb4642
DIST setuptools-54.2.0.tar.gz 2054279 BLAKE2B 2a52e76808fb2bc6df4c59ac7476a9386401180ff6c0d52a5f3d87aedf976a3057cfa0a7ddf2a4497c4c1552d5ebe4810c4bbfa127e1293f950054bddbf7d835 SHA512 b18cd075cf59b8648611eef1874de41199ede6ffe6d7f5047586c6ac8783fe18b9a4f537783e590e7aec127033f612b93925e92f039bd6416a609fcfb262e354
+DIST setuptools-56.0.0.tar.gz 2054762 BLAKE2B 3fc0f47304109f765ff0f8430dae735005d508aaa79609c5ca08217eb3802014267bd0f1a4f4678b417143f0d22b4b27f166573e41685229e0d4491b1789713d SHA512 951d43a0192b9dddacd7bd7ff6b76e281c14071771096db3c413fde6ea67b0c534f17a770cb3464cd3a6a4e8145b82f4cf5c0228e76e6f2cefe88d33748816e9
diff --git a/dev-python/setuptools/setuptools-56.0.0.ebuild b/dev-python/setuptools/setuptools-56.0.0.ebuild
new file mode 100644
index 000000000000..893b46224b3f
--- /dev/null
+++ b/dev-python/setuptools/setuptools-56.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ # network
+ 'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'
+ setuptools/tests/test_distutils_adoption.py
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # this one's unhappy about pytest-xdist but one test is not worth
+ # losing the speed gain
+ setuptools/tests/test_build_meta.py::TestBuildMetaBackend::test_build_sdist_relative_path_import
+ )
+
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${deselect[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ setuptools || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}