summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 22:09:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 23:21:11 +0100
commita8ecb2bd93b81c5183c06e0410a44a1ac41af131 (patch)
tree8c93c3c6b45ba54433bef585fbd37bd73df710ac /dev-python/setuptools
parentdev-python/jaraco-path: New dep of setuptools (diff)
downloadgentoo-a8ecb2bd93b81c5183c06e0410a44a1ac41af131.tar.gz
gentoo-a8ecb2bd93b81c5183c06e0410a44a1ac41af131.tar.bz2
gentoo-a8ecb2bd93b81c5183c06e0410a44a1ac41af131.zip
dev-python/setuptools: Bump to 54.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-54.0.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 6a638075ed35..1ebb6ed577a2 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-51.3.3.tar.gz 2053035 BLAKE2B 73b33359f10f900233b82e68c91781609665bdecb6b0e2963d7d15a798149c104030cc1e124ee945b23e5fc8db3f573d0b9012cfba7767ff913077af907141e4 SHA512 5a3572466a68c6f650111448ce3343f64c62044650bb8635edbff97e2bc7b216b8bbe3b4e3bccf34e6887f3bedc911b27ca5f9a515201cae49cf44fbacf03345
DIST setuptools-53.0.0.tar.gz 2050503 BLAKE2B b1ebe5a9776917fe9a21a13a4db613fd05aa1f61043482487013bcfed7802ff1b984fe0f72623b092eee7ebfb9debd5f71732223220bc2b73a6ece0a7ec86a2c SHA512 d045198210f09c5f2acbd487d3dd291cd7ce814bebe331f1876c133cd28f56d368717c7bd4a875b439c9cc8c9488dc9a7d3e27ab791cce419f78b87fcfd8fff6
DIST setuptools-53.1.0.tar.gz 2051159 BLAKE2B f4148df45f5c62acd6acae833619dcae50f131da91ece1a2e1231620d4800294f14dab6c72ca5b2ffd31191c4e3306a869abdba349adcec5746600fc067b340d SHA512 0ca02e9b997623268d8f73b73ee6a4b1ad513802cbc75c74124a85bd5ca7bfaea5cf7cccb706334c0dac2c8a0674a5bc2cea10f44f99f881ad893c8337af3da2
+DIST setuptools-54.0.0.tar.gz 2052086 BLAKE2B b96b8ac1119a9ece7d6a7e481a8d078f6ea65957be679549381b67e26498a6d403aca38b8ee8ca832c8e1045f960114e037787863ea6247bc87a92c1301c11fb SHA512 b13ad8aa13da63d9504064fb702632d0d17dd81eee8c09b9d38d30a6e4d625a600f0b3e7349e45354b444c25d5caccb5407bdecdd220af2e283f4baccd6f675f
diff --git a/dev-python/setuptools/setuptools-54.0.0.ebuild b/dev-python/setuptools/setuptools-54.0.0.ebuild
new file mode 100644
index 000000000000..9bc11f0ea338
--- /dev/null
+++ b/dev-python/setuptools/setuptools-54.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ # network
+ 'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'
+ setuptools/tests/test_distutils_adoption.py
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # this one's unhappy about pytest-xdist but one test is not worth
+ # losing the speed gain
+ setuptools/tests/test_build_meta.py::TestBuildMetaBackend::test_build_sdist_relative_path_import
+ )
+
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${deselect[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ setuptools || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}