summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 19:42:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 19:42:10 +0200
commitafd3eb1146389d23a0b009247bd9ef921ab9ee6b (patch)
tree8617e318502811deae4633ad99ce76d7a7c37f1d /dev-python/setuptools
parentdev-python/regex: Remove old (diff)
downloadgentoo-afd3eb1146389d23a0b009247bd9ef921ab9ee6b.tar.gz
gentoo-afd3eb1146389d23a0b009247bd9ef921ab9ee6b.tar.bz2
gentoo-afd3eb1146389d23a0b009247bd9ef921ab9ee6b.zip
dev-python/setuptools: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-45.3.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 8c39b4c49acb..07364d4167c3 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,4 +1,3 @@
DIST setuptools-44.0.0.zip 858893 BLAKE2B 02ba2a838487ba9e80d9ca3b8598cecbec4d286f2734be439d2b73f3f7f0ca80e80ea71a0c2322093deb548503c82d6eb32b1585992979b053f14f49baa00baa SHA512 bb48e7763d258e654472bc416d16ec8708eefa95d1eb03cb6e81b623fd636cefc51a0bd67887084ab0214e256e2030a8f655184c3b59ad6937abab6a6178f3a1
DIST setuptools-44.1.0.zip 858569 BLAKE2B f59f154e121502a731e51294ccd293d60ffccadacf51e23b53bf7ceba38858948b86783238061136c827ac3373ea7ea8e6253d4bb53f3f1dd69284568ec65a68 SHA512 4dfb0f42d334b835758e865a26ecd1e725711fa2b9c38ddc273b8b3849fba04527bc97436d11ba1e98f1a42922aa0f0b9032e32998273c705fac6e10735eacbf
-DIST setuptools-45.3.0.zip 862788 BLAKE2B ac2216a788db374bfe702ac11639dd850c2b947eed332067c0d923a135c9a0ba1760d56df6dd7b999ed42156d8b7a1898964d2ca0777d9e84593ae5eabcfd749 SHA512 9801f23c7e10712db0772b3d7365209df4e2a167feb5a6824809a258424a9220f65438f3087021e2484731091ea1cf3dd667308631dc8bff7807535cae528364
DIST setuptools-46.1.3.zip 862431 BLAKE2B 89d65360e15b22f535312627723ad61df84dce3ee9d5850dd0c60dace0f8c04a502ac6246afe1add1e4fbd0e0dc9530afc8bfd2a4cf058f93cde2ff4184e21f2 SHA512 7f8f99313ce2af2cbfa86ff9a3135bc3445804e9323a375b498d20dad7f8fc819481da0c2a057160397e98b6178c1eb453a093652cfdfe7896c9d31732f7ad8c
diff --git a/dev-python/setuptools/setuptools-45.3.0.ebuild b/dev-python/setuptools/setuptools-45.3.0.ebuild
deleted file mode 100644
index 17d23ae5d72b..000000000000
--- a/dev-python/setuptools/setuptools-45.3.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of extensions to Distutils"
-HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- app-arch/unzip
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
- dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- )
-"
-PDEPEND="
- >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
-
-# Force in-source build because build system modifies sources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
-
-python_prepare_all() {
- # disable tests requiring a network connection
- rm setuptools/tests/test_packageindex.py || die
-
- # don't run integration tests
- rm setuptools/tests/test_integration.py || die
-
- # avoid pointless dep on flake8
- sed -i -e 's:--flake8::' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
- # It tries to sandbox the test in a tempdir
- HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
- distutils-r1_python_install
-}