summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-13 12:23:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-13 13:33:15 +0200
commitc09787924e5272f8d6f453c274d5a6dac0904b19 (patch)
tree3f92b4a9091e2f95c8d158d0ca08eded29b098af /dev-python/setuptools
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-c09787924e5272f8d6f453c274d5a6dac0904b19.tar.gz
gentoo-c09787924e5272f8d6f453c274d5a6dac0904b19.tar.bz2
gentoo-c09787924e5272f8d6f453c274d5a6dac0904b19.zip
dev-python/setuptools: Bump to 46.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/files/setuptools-46.2.0-test-warning.patch82
-rw-r--r--dev-python/setuptools/setuptools-46.2.0.ebuild70
3 files changed, 153 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 07364d4167c3..86718e07171e 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-44.0.0.zip 858893 BLAKE2B 02ba2a838487ba9e80d9ca3b8598cecbec4d286f2734be439d2b73f3f7f0ca80e80ea71a0c2322093deb548503c82d6eb32b1585992979b053f14f49baa00baa SHA512 bb48e7763d258e654472bc416d16ec8708eefa95d1eb03cb6e81b623fd636cefc51a0bd67887084ab0214e256e2030a8f655184c3b59ad6937abab6a6178f3a1
DIST setuptools-44.1.0.zip 858569 BLAKE2B f59f154e121502a731e51294ccd293d60ffccadacf51e23b53bf7ceba38858948b86783238061136c827ac3373ea7ea8e6253d4bb53f3f1dd69284568ec65a68 SHA512 4dfb0f42d334b835758e865a26ecd1e725711fa2b9c38ddc273b8b3849fba04527bc97436d11ba1e98f1a42922aa0f0b9032e32998273c705fac6e10735eacbf
DIST setuptools-46.1.3.zip 862431 BLAKE2B 89d65360e15b22f535312627723ad61df84dce3ee9d5850dd0c60dace0f8c04a502ac6246afe1add1e4fbd0e0dc9530afc8bfd2a4cf058f93cde2ff4184e21f2 SHA512 7f8f99313ce2af2cbfa86ff9a3135bc3445804e9323a375b498d20dad7f8fc819481da0c2a057160397e98b6178c1eb453a093652cfdfe7896c9d31732f7ad8c
+DIST setuptools-46.2.0.zip 865117 BLAKE2B 490387146003e07a5391afa798d1e45a76e9afc81c3e0c484005b3b0bff15f172db2016907199fe2216a4e17379987a53d58149d285be6dcfe7c37a64ce7c359 SHA512 d8d89a99c6a3be0a343d6a0e17117ba00393188d69c8995a5dbe9a7772c002fc301a53963288231e3f8053ffda4cafd5406edb2f4650f2036c665f8e3eb5822e
diff --git a/dev-python/setuptools/files/setuptools-46.2.0-test-warning.patch b/dev-python/setuptools/files/setuptools-46.2.0-test-warning.patch
new file mode 100644
index 000000000000..e27db9a41da9
--- /dev/null
+++ b/dev-python/setuptools/files/setuptools-46.2.0-test-warning.patch
@@ -0,0 +1,82 @@
+From 56bcce894e99059a8abda29d8b919b0bee7fd1b9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Tue, 12 May 2020 13:33:04 +0200
+Subject: [PATCH] Reuse @ack_2to3 in TestDevelop.test_2to3_user_mode
+
+Fixes https://github.com/pypa/setuptools/issues/2100
+---
+ changelog.d/2105.misc.rst | 1 +
+ setuptools/tests/__init__.py | 4 +++-
+ setuptools/tests/test_develop.py | 2 ++
+ setuptools/tests/test_test.py | 4 +---
+ 4 files changed, 7 insertions(+), 4 deletions(-)
+ create mode 100644 changelog.d/2105.misc.rst
+
+diff --git a/changelog.d/2105.misc.rst b/changelog.d/2105.misc.rst
+new file mode 100644
+index 000000000..75eaf2cb3
+--- /dev/null
++++ b/changelog.d/2105.misc.rst
+@@ -0,0 +1 @@
++Filter ``2to3`` deprecation warnings from ``TestDevelop.test_2to3_user_mode``.
+diff --git a/setuptools/tests/__init__.py b/setuptools/tests/__init__.py
+index 9c77b51f8..6377d7857 100644
+--- a/setuptools/tests/__init__.py
++++ b/setuptools/tests/__init__.py
+@@ -6,7 +6,7 @@
+
+
+ __all__ = [
+- 'fail_on_ascii', 'py2_only', 'py3_only'
++ 'fail_on_ascii', 'py2_only', 'py3_only', 'ack_2to3'
+ ]
+
+
+@@ -16,3 +16,5 @@
+
+ py2_only = pytest.mark.skipif(not PY2, reason="Test runs on Python 2 only")
+ py3_only = pytest.mark.skipif(not PY3, reason="Test runs on Python 3 only")
++
++ack_2to3 = pytest.mark.filterwarnings('ignore:2to3 support is deprecated')
+diff --git a/setuptools/tests/test_develop.py b/setuptools/tests/test_develop.py
+index 792975fd1..bb89a865b 100644
+--- a/setuptools/tests/test_develop.py
++++ b/setuptools/tests/test_develop.py
+@@ -17,6 +17,7 @@
+
+ from setuptools.command.develop import develop
+ from setuptools.dist import Distribution
++from setuptools.tests import ack_2to3
+ from . import contexts
+ from . import namespaces
+
+@@ -65,6 +66,7 @@ class TestDevelop:
+ @pytest.mark.skipif(
+ in_virtualenv or in_venv,
+ reason="Cannot run when invoked in a virtualenv or venv")
++ @ack_2to3
+ def test_2to3_user_mode(self, test_env):
+ settings = dict(
+ name='foo',
+diff --git a/setuptools/tests/test_test.py b/setuptools/tests/test_test.py
+index 0f77d8ff3..892fd120d 100644
+--- a/setuptools/tests/test_test.py
++++ b/setuptools/tests/test_test.py
+@@ -10,6 +10,7 @@
+
+ from setuptools.command.test import test
+ from setuptools.dist import Distribution
++from setuptools.tests import ack_2to3
+
+ from .textwrap import DALS
+
+@@ -73,9 +74,6 @@ def quiet_log():
+ log.set_verbosity(0)
+
+
+-ack_2to3 = pytest.mark.filterwarnings('ignore:2to3 support is deprecated')
+-
+-
+ @pytest.mark.usefixtures('sample_test', 'quiet_log')
+ @ack_2to3
+ def test_test(capfd):
diff --git a/dev-python/setuptools/setuptools-46.2.0.ebuild b/dev-python/setuptools/setuptools-46.2.0.ebuild
new file mode 100644
index 000000000000..ff041cbacee4
--- /dev/null
+++ b/dev-python/setuptools/setuptools-46.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-warning.patch
+)
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ # xpass-es for me
+ sed -i -e '/xfail.*710/d' setuptools/tests/test_archive_util.py || die
+
+ # avoid pointless dep on flake8
+ sed -i -e 's:--flake8::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}