summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-28 10:01:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-28 10:03:04 +0200
commiteb3a15f2348527a41e97c85452e01ed246ce4258 (patch)
treedadf91d71e53caf38b561506cd23880acc2d010e /dev-python/setuptools
parentprofiles/arch/arm: Mask py39 (diff)
downloadgentoo-eb3a15f2348527a41e97c85452e01ed246ce4258.tar.gz
gentoo-eb3a15f2348527a41e97c85452e01ed246ce4258.tar.bz2
gentoo-eb3a15f2348527a41e97c85452e01ed246ce4258.zip
dev-python/setuptools: Reenable tests
Closes: https://bugs.gentoo.org/725492 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/setuptools-46.4.0-r1.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/setuptools/setuptools-46.4.0-r1.ebuild b/dev-python/setuptools/setuptools-46.4.0-r1.ebuild
index 3e7d069b4f86..07b818e2943a 100644
--- a/dev-python/setuptools/setuptools-46.4.0-r1.ebuild
+++ b/dev-python/setuptools/setuptools-46.4.0-r1.ebuild
@@ -21,14 +21,12 @@ RESTRICT="!test? ( test )"
BDEPEND="
app-arch/unzip
test? (
- $(python_gen_cond_dep '
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pip[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
- dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
- dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- ' python2_7 python3_{6,7,8} pypy3)
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/futures[${PYTHON_USEDEP}]
' -2)
@@ -65,11 +63,6 @@ python_prepare_all() {
}
python_test() {
- if [[ ${EPYTHON} == python3.9 ]]; then
- einfo "Tests are skipped on py3.9 due to unported deps"
- return
- fi
-
distutils_install_for_testing
# test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
# It tries to sandbox the test in a tempdir