summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-09-11 21:58:06 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-09-11 21:58:06 +0700
commit402ff1f1c0707f47b3d72fdd6bc5364444d75efa (patch)
treec9e14c4471596980a09b984e59380bc8e0e497e8 /dev-python/sh
parentnet-irc/unrealircd: Bump 3.x to unrealircd-3.2.10.7 for bug #593294. (diff)
downloadgentoo-402ff1f1c0707f47b3d72fdd6bc5364444d75efa.tar.gz
gentoo-402ff1f1c0707f47b3d72fdd6bc5364444d75efa.tar.bz2
gentoo-402ff1f1c0707f47b3d72fdd6bc5364444d75efa.zip
dev-python/sh: python3_5 added
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/sh-1.11-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.11-r1.ebuild b/dev-python/sh/sh-1.11-r1.ebuild
new file mode 100644
index 000000000000..d7887107d787
--- /dev/null
+++ b/dev-python/sh/sh-1.11-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} test.py || die
+}