summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-18 12:21:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-18 12:23:18 +0200
commitf2581accf1511bcaf956b483217d9d67d022c75c (patch)
treeb01a664f5823daeec0dc7d5f45772fa8e9b0355e /dev-python/shiboken2
parentdev-java/gson: remove obsolete 2.7-r1 (diff)
downloadgentoo-f2581accf1511bcaf956b483217d9d67d022c75c.tar.gz
gentoo-f2581accf1511bcaf956b483217d9d67d022c75c.tar.bz2
gentoo-f2581accf1511bcaf956b483217d9d67d022c75c.zip
dev-python/shiboken2: depend on clang-runtime
pyside2 fails to compile if we try to compile it with a different version of clang then was present when shiboken2 was compiled. Even a change of the minor version triggers this! We depend on clang-runtime as well as on clang, because clang-PV pulls in clang-runtime-PV and the clang-runtime ebuild defines different slots even for the minor releases (which clang does not, it only has slots for major releases). This should trigger a rebuild of shiboken2 even for minor version changes of clang(-runtime) and thus avoid any issues when compiling pyside2. Closes: https://bugs.gentoo.org/796614 Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/shiboken2')
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.1-r1.ebuild (renamed from dev-python/shiboken2/shiboken2-5.15.1.ebuild)3
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild (renamed from dev-python/shiboken2/shiboken2-5.15.2.ebuild)3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/shiboken2/shiboken2-5.15.1.ebuild b/dev-python/shiboken2/shiboken2-5.15.1-r1.ebuild
index 7acae0aa868b..de2845464e89 100644
--- a/dev-python/shiboken2/shiboken2-5.15.1.ebuild
+++ b/dev-python/shiboken2/shiboken2-5.15.1-r1.ebuild
@@ -41,7 +41,8 @@ QT_PV="$(ver_cut 1-2):5"
# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
RDEPEND="${PYTHON_DEPS}
>=dev-qt/qtcore-${QT_PV}
- >=sys-devel/clang-6:=
+ sys-devel/clang:=
+ sys-devel/clang-runtime:=
docstrings? (
>=dev-libs/libxml2-2.6.32
>=dev-libs/libxslt-1.1.19
diff --git a/dev-python/shiboken2/shiboken2-5.15.2.ebuild b/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
index 0f97bbc648a2..cbfac4a28fb9 100644
--- a/dev-python/shiboken2/shiboken2-5.15.2.ebuild
+++ b/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
@@ -44,7 +44,8 @@ QT_PV="$(ver_cut 1-2):5"
# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
RDEPEND="${PYTHON_DEPS}
>=dev-qt/qtcore-${QT_PV}
- >=sys-devel/clang-6:=
+ sys-devel/clang:=
+ sys-devel/clang-runtime:=
docstrings? (
>=dev-libs/libxml2-2.6.32
>=dev-libs/libxslt-1.1.19