summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-29 17:03:47 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-29 17:41:47 +0100
commitd5f5cbd2f9f75252d653db361cf06cb7bd908dad (patch)
tree5414d9684d36fe90ebaeddb63e84557d553386d6 /dev-python/simplebayes
parentnet-print/cndrvcups-common-lb: Respect AR, prune static-libs (diff)
downloadgentoo-d5f5cbd2f9f75252d653db361cf06cb7bd908dad.tar.gz
gentoo-d5f5cbd2f9f75252d653db361cf06cb7bd908dad.tar.bz2
gentoo-d5f5cbd2f9f75252d653db361cf06cb7bd908dad.zip
dev-python/simplebayes: ebuild 1.5.8 bump
This uses pypi tarball, github 1.5.7 is equivalent Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-python/simplebayes')
-rw-r--r--dev-python/simplebayes/Manifest1
-rw-r--r--dev-python/simplebayes/simplebayes-1.5.8.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/simplebayes/Manifest b/dev-python/simplebayes/Manifest
index 17d1ed2b6eb0..b1783ce7c375 100644
--- a/dev-python/simplebayes/Manifest
+++ b/dev-python/simplebayes/Manifest
@@ -1 +1,2 @@
DIST simplebayes-1.5.7.tar.gz 19260 BLAKE2B 373820a19c1a3188f0dfb57cbe6ac8e27fc6a96e9d1686d698a1f109122afd5240715678d965d843482de3c12b8b806157acef17008d4c6fac0103b343dd44d7 SHA512 417af72db13418e5a9df2fdb642fc63ed3eb4fbbf88cc7252a9e3603d31e35ccb68ae5838d8bb7d77554c1820a9db8aa944c639af4eb6418babb9d360ef3ddbc
+DIST simplebayes-1.5.8.tar.gz 5972 BLAKE2B f942ccde5f449d0ef8ef56fb83a07a8ab0421f43e5af40a3be30822a5d7299b9a0cb1d46397a55bcf7fecc92e40f49404f5bf29467acf7957fbce8619625b58b SHA512 0e39110432db561208cf147bccbdb66f64176a78c0e9ce8495a423ed0d6a027b45deb111d3c872faa10e158fcdaa5380f03a5e0602fecea1a0f00e528e19cfe1
diff --git a/dev-python/simplebayes/simplebayes-1.5.8.ebuild b/dev-python/simplebayes/simplebayes-1.5.8.ebuild
new file mode 100644
index 000000000000..efe01695e0b0
--- /dev/null
+++ b/dev-python/simplebayes/simplebayes-1.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="memory-based, optional-persistence naive bayesian text classifier"
+HOMEPAGE="https://github.com/hickeroar/simplebayes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}