summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-02-12 04:55:07 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-02-12 04:55:30 +0100
commit297d3fc0cfeb01b4627e1dd02a40065296d0a718 (patch)
tree304b179243b49bdc8c78925c03b85432c3556a19 /dev-python/sip
parentdev-python/sip: remove 4.19.8 (diff)
downloadgentoo-297d3fc0cfeb01b4627e1dd02a40065296d0a718.tar.gz
gentoo-297d3fc0cfeb01b4627e1dd02a40065296d0a718.tar.bz2
gentoo-297d3fc0cfeb01b4627e1dd02a40065296d0a718.zip
dev-python/sip: bump to 4.19.14 final
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest2
-rw-r--r--dev-python/sip/sip-4.19.14.ebuild (renamed from dev-python/sip/sip-4.19.14_pre1812231555.ebuild)10
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index df0259105904..7a6fb1f2d612 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,2 +1,2 @@
DIST sip-4.19.13.tar.gz 1038815 BLAKE2B 0b6f2941140a535cfdfb51db71cf9a55e5f65be85961e304496fded7781da42b0ab7d01045b8802468a3ce3b57e7f571851fc7713fd47a03c8344017982d6632 SHA512 eb456e1f7efa463f859047acc5301e19279e1627629d0bad3ac7a0a52b77575126bc3f2c64bb4278ae11d415c13d2731dfc8c816bba71307173d393a414aae98
-DIST sip-4.19.14.dev1812231555.tar.gz 1020224 BLAKE2B e3df5a8b7829278987c5b368b8b6c28c04fc0b3bb3847451e48411ef9ba5cda932007613ad31f34381446ea02d62281b27ae4951babca5ec8b75f065aa296365 SHA512 decf2f7baacede27c42d359eb875a895c9a92b36a8e8a29f4666b3f98f570d821e80dbb32fd946ce230f726fafc4000af9b167df8cfd188bcd7f85fbc71bd4b1
+DIST sip-4.19.14.tar.gz 1049688 BLAKE2B 8e68910f533d0f58bef1f20ec58579ce0166efaee2caef1c64d4e9878b0887040d9284a9fa5ee48d7a4f0949866d0b988b0d962303f0ace03a4ad48bd08eec5d SHA512 afde261331f38eac863d8cea0e343649f460f0b9a603d7fe91f14583904ea4b488bbd88d20fad5c985c43c6c1683fffee38676d94831ac8f2de40d9ed4d0423e
diff --git a/dev-python/sip/sip-4.19.14_pre1812231555.ebuild b/dev-python/sip/sip-4.19.14.ebuild
index 47ab306936cb..23d98f6e9a42 100644
--- a/dev-python/sip/sip-4.19.14_pre1812231555.ebuild
+++ b/dev-python/sip/sip-4.19.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,14 +13,14 @@ MY_P=${P/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
else
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
fi
# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h
SLOT="0/12"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug doc"
+IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -49,12 +49,11 @@ src_prepare() {
src_configure() {
configuration() {
- local incdir=$(python_get_includedir)
-
if ! python_is_python3; then
local CFLAGS="${CFLAGS} -fno-strict-aliasing"
fi
+ local incdir=$(python_get_includedir)
local myconf=(
"${PYTHON}"
"${S}"/configure.py
@@ -62,7 +61,6 @@ src_configure() {
--bindir="${EPREFIX}/usr/bin"
--destdir="$(python_get_sitedir)"
--incdir="${incdir#${SYSROOT}}"
- $(usex debug --debug '')
AR="$(tc-getAR) cqs"
CC="$(tc-getCC)"
CFLAGS="${CFLAGS}"