summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-10-07 20:03:42 +0200
committerDavide Pesavento <pesa@gentoo.org>2018-10-07 20:08:07 +0200
commitb7c8a0c96ed43e3e8f379ace7de581548b8c9764 (patch)
treed808af20c9f3e2449e3733060797c7c78e528bdb /dev-python/sip
parentmedia-fonts/unifont: Version 11.0.02. (diff)
downloadgentoo-b7c8a0c96ed43e3e8f379ace7de581548b8c9764.tar.gz
gentoo-b7c8a0c96ed43e3e8f379ace7de581548b8c9764.tar.bz2
gentoo-b7c8a0c96ed43e3e8f379ace7de581548b8c9764.zip
dev-python/sip: remove 4.19.12
Signed-off-by: Davide Pesavento <pesa@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-4.19.12.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 90e17b7bc0ff..bf6364200f30 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,2 @@
-DIST sip-4.19.12.tar.gz 1036410 BLAKE2B 11f7df2ddafe0ceb1edd75d3cc5128c32d7aa2e9a77ad4555d69bcafc87f8141384928cdf2481c324998b2e224920b50c0f397d67314370ce30cca6d7a02a15a SHA512 9b9680172357aaf4a1ebc3bf1f4d2badaaa8643e50665fed6e17d27283a499ceac56c4f1db190de4d9516c8f0f794159485cc6f8fd68daafcbe1ccac85161972
DIST sip-4.19.13.tar.gz 1038815 BLAKE2B 0b6f2941140a535cfdfb51db71cf9a55e5f65be85961e304496fded7781da42b0ab7d01045b8802468a3ce3b57e7f571851fc7713fd47a03c8344017982d6632 SHA512 eb456e1f7efa463f859047acc5301e19279e1627629d0bad3ac7a0a52b77575126bc3f2c64bb4278ae11d415c13d2731dfc8c816bba71307173d393a414aae98
DIST sip-4.19.8.tar.gz 1024548 BLAKE2B e43dfe542061db9f1d5981d0cc172d9c8420c4e66c282c52974ab28314c33bd28e6056b61f74b04680c1735c9bd2c4656e1a541f4bae94c858d18713f6222914 SHA512 9c0a9722a9a9dd23e2eabe751d622cdd31b376b7987b2c991f5ef4a8d11853c5c6e9f1c24a0d2d864d3990e2a45c2a159ca8511efd4a7e156a14937ef3c680f7
diff --git a/dev-python/sip/sip-4.19.12.ebuild b/dev-python/sip/sip-4.19.12.ebuild
deleted file mode 100644
index 3313a4fac4da..000000000000
--- a/dev-python/sip/sip-4.19.12.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
-
-inherit python-r1 toolchain-funcs
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
-
-if [[ ${PV} == *9999 ]]; then
- inherit mercurial
- EHG_REPO_URI="https://www.riverbankcomputing.com/hg/sip"
-elif [[ ${PV} == *_pre* ]]; then
- MY_P=${P/_pre/.dev}
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
- S=${WORKDIR}/${MY_P}
-else
- SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
-fi
-
-# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h
-SLOT="0/12"
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug doc"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-if [[ ${PV} == *9999 ]]; then
- DEPEND+="
- sys-devel/bison
- sys-devel/flex
- doc? ( dev-python/sphinx[$(python_gen_usedep 'python2*')] )"
-fi
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-if [[ ${PV} == *9999 ]]; then
- REQUIRED_USE+=" || ( $(python_gen_useflags 'python2*') )"
-fi
-
-PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
-
-src_prepare() {
- if [[ ${PV} == *9999 ]]; then
- python_setup 'python2*'
- "${PYTHON}" build.py prepare || die
- if use doc; then
- "${PYTHON}" build.py doc || die
- fi
- fi
-
- # Sub-slot sanity check
- local sub_slot=${SLOT#*/}
- local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h || die)
- if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
- eerror
- eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- default
-}
-
-src_configure() {
- configuration() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
-
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --incdir="$(python_get_includedir)"
- $(usex debug --debug '')
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake DESTDIR="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
- use doc && dodoc -r doc/html
-}