summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-03-04 21:22:31 +0100
committerDavide Pesavento <pesa@gentoo.org>2018-03-04 21:22:31 +0100
commite3f546a1a24a559b7ce79840839d17c16d2c8ec2 (patch)
tree7586f7f63e2d27741a42efd62579183d743f6fe1 /dev-python/sip
parentapp-portage/etc-proposals: Drop USE=gtk,qt4 (diff)
downloadgentoo-e3f546a1a24a559b7ce79840839d17c16d2c8ec2.tar.gz
gentoo-e3f546a1a24a559b7ce79840839d17c16d2c8ec2.tar.bz2
gentoo-e3f546a1a24a559b7ce79840839d17c16d2c8ec2.zip
dev-python/sip: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-4.19.8.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index c0e26923afb7..30b9d95de2b4 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,4 @@
DIST sip-4.19.3.tar.gz 1007481 BLAKE2B cf4d53c956aa046f165e9ec05126fa9b6ca3df688b16ff79520da8ea82f7e9622e03448030db14b0d21ba090893375814f39d6b3fc62343880aa169c2680394f SHA512 b2dea0cb5e1b23531f35e94bd604ec9874f0875badb5b20eb5abd2732a1005b2dd15bb42e0007b65053a2153b50659f24671abd83a434991661168a5778b94bc
DIST sip-4.19.6.tar.gz 1019295 BLAKE2B 107bc63b8c0f200c292bbf465507602904383a1d3fd0b76da907cda2dcf0e79edb9cbf835bc15dbefd991db6a7eeff97462965d88704e3c926ce9e0dd5af829f SHA512 1bfd2da8b0ece6156aa94713d5e9ced6226b7f49427ca4a11b65452a67e9c740b93a1f90c00a0636d4eef8a31324988a84373c15194f64774b6f8c084d0464f7
DIST sip-4.19.7.tar.gz 1022209 BLAKE2B 51b29bd436ce7af2d4a3b45ace100075bd257c23982c6e1fcd3f8b2998ee360f1ac42683fbd0e3a371cb044a682c326e00e907db0961aebc70bfb6b583ad2bc7 SHA512 0cead34e129d25ee3d908e503a3853289bbfd77c58c563a2046ce7b65bd8f0b318b20af72346cbf4cb7a17e76c9c1374f686b5dabc284d7247897a1648c15f97
+DIST sip-4.19.8.tar.gz 1024548 BLAKE2B e43dfe542061db9f1d5981d0cc172d9c8420c4e66c282c52974ab28314c33bd28e6056b61f74b04680c1735c9bd2c4656e1a541f4bae94c858d18713f6222914 SHA512 9c0a9722a9a9dd23e2eabe751d622cdd31b376b7987b2c991f5ef4a8d11853c5c6e9f1c24a0d2d864d3990e2a45c2a159ca8511efd4a7e156a14937ef3c680f7
diff --git a/dev-python/sip/sip-4.19.8.ebuild b/dev-python/sip/sip-4.19.8.ebuild
new file mode 100644
index 000000000000..08a8e8d93775
--- /dev/null
+++ b/dev-python/sip/sip-4.19.8.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit python-r1 toolchain-funcs
+
+DESCRIPTION="Python extension module generator for C and C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://www.riverbankcomputing.com/hg/sip"
+elif [[ ${PV} == *_pre* ]]; then
+ MY_P=${P/_pre/.dev}
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+else
+ SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
+fi
+
+# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
+SLOT="0/12"
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+if [[ ${PV} == *9999 ]]; then
+ DEPEND+="
+ sys-devel/bison
+ sys-devel/flex
+ doc? ( dev-python/sphinx[$(python_gen_usedep 'python2*')] )"
+fi
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+if [[ ${PV} == *9999 ]]; then
+ REQUIRED_USE+=" || ( $(python_gen_useflags 'python2*') )"
+fi
+
+PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
+
+src_prepare() {
+ if [[ ${PV} == *9999 ]]; then
+ python_setup 'python2*'
+ "${PYTHON}" build.py prepare || die
+ if use doc; then
+ "${PYTHON}" build.py doc || die
+ fi
+ fi
+
+ # Sub-slot sanity check
+ local sub_slot=${SLOT#*/}
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
+ if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
+ eerror
+ eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ default
+}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --bindir="${EPREFIX}/usr/bin"
+ --destdir="$(python_get_sitedir)"
+ --incdir="$(python_get_includedir)"
+ $(usex debug --debug '')
+ AR="$(tc-getAR) cqs"
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CFLAGS_RELEASE=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ CXXFLAGS_RELEASE=
+ LINK="$(tc-getCXX)"
+ LINK_SHLIB="$(tc-getCXX)"
+ LFLAGS="${LDFLAGS}"
+ LFLAGS_RELEASE=
+ RANLIB=
+ STRIP=
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake DESTDIR="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+ use doc && dodoc -r doc/html
+}