summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-03-10 21:33:24 -0500
committerMike Gilbert <floppym@gentoo.org>2016-03-10 21:33:24 -0500
commit965b59bad230d17c28ff735446c593c9887be71e (patch)
treebeab19498cdae02045c2fd30362ff3080b937174 /dev-python/six
parentsys-fs/btrfs-progs: Bump to 4.4.1 (diff)
downloadgentoo-965b59bad230d17c28ff735446c593c9887be71e.tar.gz
gentoo-965b59bad230d17c28ff735446c593c9887be71e.tar.bz2
gentoo-965b59bad230d17c28ff735446c593c9887be71e.zip
dev-python/six: Add a strong warning for the next version bump
Package-Manager: portage-2.2.28_p57
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index f0d2eef16da1..b005475fb6c6 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,6 +26,15 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+if [[ ${PV} != 1.10.0 ]]; then
+ # There is no longer a circular dep with setuptools, so please do the following
+ # Drop 1.10.0-no-setuptools.patch
+ # Add a dependency on dev-python/setuptools[${PYTHON_USEDEP}]
+ # Remove pkg_preinst
+ # Thanks! - Mike Gilbert (floppym)
+ die "Please read the ebuild for notes on this version bump"
+fi
+
python_prepare_all() {
# https://bitbucket.org/gutworth/six/issues/139/
sed \