summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:50:32 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitdfce6a79b3de9cb1441113f98bafae1a4f342cfc (patch)
treeb6373c6119d15e51b8e424fdeb88fa1e8b614cb0 /dev-python/six
parentdev-python/testscenarios: Add python3.5 support (diff)
downloadgentoo-dfce6a79b3de9cb1441113f98bafae1a4f342cfc.tar.gz
gentoo-dfce6a79b3de9cb1441113f98bafae1a4f342cfc.tar.bz2
gentoo-dfce6a79b3de9cb1441113f98bafae1a4f342cfc.zip
dev-python/six: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0-r1.ebuild b/dev-python/six/six-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..f5c53b6ef577
--- /dev/null
+++ b/dev-python/six/six-1.10.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://bitbucket.org/gutworth/six https://pypi.python.org/pypi/six"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/1.9.0-mapping.patch
+ )
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/ )
+ distutils-r1_python_install_all
+}