summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/slowaes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/slowaes')
-rw-r--r--dev-python/slowaes/Manifest1
-rw-r--r--dev-python/slowaes/metadata.xml20
-rw-r--r--dev-python/slowaes/slowaes-0.1-r1.ebuild23
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/slowaes/Manifest b/dev-python/slowaes/Manifest
new file mode 100644
index 000000000000..a901de7aa009
--- /dev/null
+++ b/dev-python/slowaes/Manifest
@@ -0,0 +1 @@
+DIST slowaes-0.1a1.tar.gz 7017 SHA256 83658ae54cc116b96f7fdb12fdd0efac3a4e8c7c7064e3fac3f4a881aa54bf09 SHA512 09126a6cf2a0da27c45b12d25c3a9147f47448311f9e36b6db2aa62d8b85f3fdf66f10f8f5d84edf48cde7f6c766d9ed384832f9ca0e28f95104149a7f424d95 WHIRLPOOL 85090de0ddb947470bc932ddc80f28316bd193329711c9e4e83982914ab18379b0fbdd986c087ba1ea9929a80bb0975bc09610a92d3b0d3d05d046e561c3f27e
diff --git a/dev-python/slowaes/metadata.xml b/dev-python/slowaes/metadata.xml
new file mode 100644
index 000000000000..8de95c1970cf
--- /dev/null
+++ b/dev-python/slowaes/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>luke-jr+gentoobugs@utopios.org</email>
+ <name>Luke Dashjr</name>
+ </maintainer>
+ <maintainer>
+ <email>maksverver@geocities.com</email>
+ <name>Maks Verver</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">slowaes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/slowaes/slowaes-0.1-r1.ebuild b/dev-python/slowaes/slowaes-0.1-r1.ebuild
new file mode 100644
index 000000000000..91c240785bba
--- /dev/null
+++ b/dev-python/slowaes/slowaes-0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P=${P}a1
+DESCRIPTION="AES implementation in pure Python"
+HOMEPAGE="http://code.google.com/p/slowaes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPENDS="dev-python/setuptools"
+
+S=${WORKDIR}/${MY_P}