summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-04 15:28:06 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-04 15:31:22 -0500
commitdb3a5a70d0520dfc37b8d1fb8357f713074b1c34 (patch)
treece4c2a33bc722bc5983fa6e9775639523070593f /dev-python/snakeoil/snakeoil-0.7.4.ebuild
parentsys-auth/pam_pkcs11: treeclean (diff)
downloadgentoo-db3a5a70d0520dfc37b8d1fb8357f713074b1c34.tar.gz
gentoo-db3a5a70d0520dfc37b8d1fb8357f713074b1c34.tar.bz2
gentoo-db3a5a70d0520dfc37b8d1fb8357f713074b1c34.zip
dev-python/snakeoil: version bump to 0.7.4
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.7.4.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.7.4.ebuild b/dev-python/snakeoil/snakeoil-0.7.4.ebuild
new file mode 100644
index 000000000000..c037456a6ebe
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.7.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
+
+python_configure_all() {
+ # disable snakeoil 2to3 caching
+ unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+ esetup.py test
+}