summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 16:21:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 17:23:29 +0200
commit7ca0131b134653369d2765fbe4c3c232a16e206e (patch)
tree2fb115dd877f83fa8f601269ba7548166c4639d8 /dev-python/snappy
parentdev-python/wsaccel: Enable py3.11 (diff)
downloadgentoo-7ca0131b134653369d2765fbe4c3c232a16e206e.tar.gz
gentoo-7ca0131b134653369d2765fbe4c3c232a16e206e.tar.bz2
gentoo-7ca0131b134653369d2765fbe4c3c232a16e206e.zip
dev-python/snappy: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/snappy')
-rw-r--r--dev-python/snappy/snappy-0.6.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/snappy/snappy-0.6.1.ebuild b/dev-python/snappy/snappy-0.6.1.ebuild
index 2d2b76271cae..3cf02af40dda 100644
--- a/dev-python/snappy/snappy-0.6.1.ebuild
+++ b/dev-python/snappy/snappy-0.6.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -12,7 +12,10 @@ MY_PN=python-${PN}
MY_P=${MY_PN}-${PV}
DESCRIPTION="Python library for the snappy compression library from Google"
-HOMEPAGE="https://pypi.org/project/python-snappy/"
+HOMEPAGE="
+ https://github.com/andrix/python-snappy/
+ https://pypi.org/project/python-snappy/
+"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
@@ -20,8 +23,12 @@ LICENSE="BSD"
KEYWORDS="amd64 arm arm64 ~riscv x86 ~amd64-linux ~x86-linux"
SLOT="0"
-DEPEND=">=app-arch/snappy-1.0.2:="
-RDEPEND=${DEPEND}
+DEPEND="
+ >=app-arch/snappy-1.0.2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
python_test() {
cp test*.py "${BUILD_DIR}" || die