summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 16:35:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 17:01:19 +0200
commit203bbca4da5fef507f55cb63e7ee8fad7ac390e9 (patch)
treec0a87bf4b9326f4f552e86f64c91193c92ab4ad8 /dev-python/sortedcontainers
parentdev-python/six: EAPI 8, PEP517 (diff)
downloadgentoo-203bbca4da5fef507f55cb63e7ee8fad7ac390e9.tar.gz
gentoo-203bbca4da5fef507f55cb63e7ee8fad7ac390e9.tar.bz2
gentoo-203bbca4da5fef507f55cb63e7ee8fad7ac390e9.zip
dev-python/sortedcontainers: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sortedcontainers')
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..2f98d6ff06e2
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.4.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="
+ http://www.grantjenks.com/docs/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --ignore docs/conf.py
+}