summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-07 09:08:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 09:08:23 +0200
commit3280a547bcb024268f5d554ed8b36f308f6ff910 (patch)
tree9237ee12c96be4e1cb4df6a5fed2daf423947ea7 /dev-python/sortedcontainers
parentdev-python/gevent: Bump to 20.6.0 (diff)
downloadgentoo-3280a547bcb024268f5d554ed8b36f308f6ff910.tar.gz
gentoo-3280a547bcb024268f5d554ed8b36f308f6ff910.tar.bz2
gentoo-3280a547bcb024268f5d554ed8b36f308f6ff910.zip
dev-python/sortedcontainers: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sortedcontainers')
-rw-r--r--dev-python/sortedcontainers/Manifest1
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/Manifest b/dev-python/sortedcontainers/Manifest
index fe3923871e98..c9ed13d4b337 100644
--- a/dev-python/sortedcontainers/Manifest
+++ b/dev-python/sortedcontainers/Manifest
@@ -1 +1,2 @@
DIST python-sortedcontainers-2.1.0.gh.tar.gz 9220860 BLAKE2B a667fa817f0b240b8af9758d5d3942710cfe6a39109c41e6e66d0dd464b300d2201a679335e418442aaa6e1953e38a43b46c2bd6ce631b7c168d6173ca36998e SHA512 1c56daea5d491dbeea9c677677a79ef5c4805325ea3d5da97005cd3b269003a99459550a793dfe65820f152c774371472ba471a7daf61c9d97b36744bafb013b
+DIST python-sortedcontainers-2.2.1.gh.tar.gz 9228694 BLAKE2B ccbcaf8ef1582c3229cfd82699b642c9cd86db69f68cca56d35fab05fe6b8bef5281af53eae3b697b1a8d7aaad9140d2f3de611eeb5774319a64ff9c5fc602be SHA512 d4a45c4db9ec86c83c71506525a452fd5716818326635f69fb6e830d86803c5d39821678cb67e142ddd1ae9d093f9bb583c29b6bdc59a18a5ec0213eea4a1e29
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild
new file mode 100644
index 000000000000..e70f737c3eb3
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH=.
+ pytest -vv --ignore docs/conf.py || die "Tests fail with ${EPYTHON}"
+}