summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-09-04 20:18:10 -0700
committerZac Medico <zmedico@gentoo.org>2018-09-04 20:34:36 -0700
commit54e68e1e090c00457a1688df88489516406dc66e (patch)
tree3bb4cc88cd87409e93f65ed04f23445d7bbf7c96 /dev-python/sphinx-aiohttp-theme
parentdev-python/async_generator: new package (diff)
downloadgentoo-54e68e1e090c00457a1688df88489516406dc66e.tar.gz
gentoo-54e68e1e090c00457a1688df88489516406dc66e.tar.bz2
gentoo-54e68e1e090c00457a1688df88489516406dc66e.zip
dev-python/sphinx-aiohttp-theme: new package
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/sphinx-aiohttp-theme')
-rw-r--r--dev-python/sphinx-aiohttp-theme/Manifest1
-rw-r--r--dev-python/sphinx-aiohttp-theme/metadata.xml11
-rw-r--r--dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.4.ebuild25
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sphinx-aiohttp-theme/Manifest b/dev-python/sphinx-aiohttp-theme/Manifest
new file mode 100644
index 000000000000..03d16a6d9ccf
--- /dev/null
+++ b/dev-python/sphinx-aiohttp-theme/Manifest
@@ -0,0 +1 @@
+DIST aiohttp-theme-0.1.4.tar.gz 10723 BLAKE2B afc398bb65e69fcc931f214c613f789da07c89bafd26ff207d4c5666edbe323f77c4a6fec09817d4dc6bb1d40e21ddd82f0b7b5c25dc5fe89b8b83c1c423bad7 SHA512 b487c9095a677baf9471b93be5b9cc3a697f62d2674d27ea4a7aee043e5dd75c5543a0e0a2e51c28e36e5bbf324bcb6d06786b31ae3b492ad2f972c6776c40af
diff --git a/dev-python/sphinx-aiohttp-theme/metadata.xml b/dev-python/sphinx-aiohttp-theme/metadata.xml
new file mode 100644
index 000000000000..b7700e6c436f
--- /dev/null
+++ b/dev-python/sphinx-aiohttp-theme/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aio-libs/aiohttp-theme</remote-id>
+ <remote-id type="pypi">aiohttp-theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.4.ebuild b/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.4.ebuild
new file mode 100644
index 000000000000..e4a37d75b9e1
--- /dev/null
+++ b/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+MY_PN="aiohttp-theme"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sphinx theme for aiohttp"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-theme"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"