summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-03 02:42:04 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-04 06:02:04 +0000
commit0ef27c60ebc1d8b3103e943efe35e4173584682b (patch)
treea170437899bda91928ef618963b6bcc57d5bf740 /dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
parentdev-util/eric: version bump (diff)
downloadgentoo-0ef27c60ebc1d8b3103e943efe35e4173584682b.tar.gz
gentoo-0ef27c60ebc1d8b3103e943efe35e4173584682b.tar.bz2
gentoo-0ef27c60ebc1d8b3103e943efe35e4173584682b.zip
dev-python/sphinx-gallery: fix nose depedency
And add basic testing. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild')
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..7f9ae300f5a9
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+# yes nose is somehow required besides testing
+DEPEND="
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ echo 'backend: agg' > matplotlibrc
+ VARTEXFONTS="${T}"/fonts MPLCONFIGDIR="${BUILD_DIR}" \
+ nosetests -v || die
+}