summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-23 04:46:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-23 05:05:28 +0200
commit21908eeb4cc5aa4598581690d21305be5af5a621 (patch)
tree32987673f4c4b76a7ae936a092812177795c7d0f /dev-python/sphinx-tabs
parentdev-python/uvloop: Bump to 0.19.0 (diff)
downloadgentoo-21908eeb4cc5aa4598581690d21305be5af5a621.tar.gz
gentoo-21908eeb4cc5aa4598581690d21305be5af5a621.tar.bz2
gentoo-21908eeb4cc5aa4598581690d21305be5af5a621.zip
dev-python/sphinx-tabs: Bump to 3.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-tabs')
-rw-r--r--dev-python/sphinx-tabs/Manifest1
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.4.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sphinx-tabs/Manifest b/dev-python/sphinx-tabs/Manifest
index 741ae43b25cd..85cca3f7fe1c 100644
--- a/dev-python/sphinx-tabs/Manifest
+++ b/dev-python/sphinx-tabs/Manifest
@@ -1 +1,2 @@
DIST sphinx-tabs-3.4.1.gh.tar.gz 524071 BLAKE2B 5aecb9c22a298c1347bf82cbbc16709f3f6cd38b0f0f6e4948411f1fdd79ba17d3e75178b8c092df7b8abc812dd4b0102879774708552a062aad0fe0b0653717 SHA512 b6079d3ae91479d40aaf35926226eb7dd783de7cec0e721cb13a036fc520bb3afda0dffb0669dc5054fc665125c3620261b1ea7ffe685d5b177bc980e3b4d7e4
+DIST sphinx-tabs-3.4.4.gh.tar.gz 524297 BLAKE2B 5361006ca99be157f01a7efd6ea50bbd87c1672caf0badbbde11ef832dddfd40232723fc5900a37fdb18112c5e4ddd9717829e96fd6e3afad8205c11c209d439 SHA512 365c472e88016e5c2d83a509d617ff13fc2c8c0a35fa9626244de9af2a242c2bbc4941241b3d1d863d261b15967a5694a0edb6c1d5614dce9d72531ea5138e03
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.4.4.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.4.4.ebuild
new file mode 100644
index 000000000000..6980b27acb71
--- /dev/null
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.4.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tabbed views for Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/sphinx-tabs/
+ https://pypi.org/project/sphinx-tabs/
+"
+SRC_URI="
+ https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # Unpackaged rinohtype
+ tests/test_build.py::test_rinohtype_pdf
+)
+
+src_prepare() {
+ # annoying, incorrect version limitations
+ sed -i -e '/install_requires/d' setup.py || die
+
+ distutils-r1_src_prepare
+}