summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 22:31:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 01:23:47 +0100
commit0ace91d037ec40709932f45aaf7572ebda883b2b (patch)
treea9ff97a279816e86d7d47777a6235ace293e77e5 /dev-python/sphobjinv
parentsys-apps/inxi: bump to 3.3.12.1 (diff)
downloadgentoo-0ace91d037ec40709932f45aaf7572ebda883b2b.tar.gz
gentoo-0ace91d037ec40709932f45aaf7572ebda883b2b.tar.bz2
gentoo-0ace91d037ec40709932f45aaf7572ebda883b2b.zip
dev-python/sphobjinv: Bump to 2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphobjinv')
-rw-r--r--dev-python/sphobjinv/Manifest1
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
index 6fa2f2762a66..0681c1bf6e6e 100644
--- a/dev-python/sphobjinv/Manifest
+++ b/dev-python/sphobjinv/Manifest
@@ -1 +1,2 @@
DIST sphobjinv-2.1.tar.gz 1144017 BLAKE2B 71878e1bac5202ab74298b56cd6172236ea524050323e0d6b8bbc0c89f1937d75f10d40b4071cfbe8c9031641e9a0ecb283da908c40840a61c12a7c892438241 SHA512 cde77d73b09b72358b0ac5b0d8f1a748e78dce6664d1b849ba68f5ff70dc43cbcff4581374d0151be29c4d97efe2920c5c00ff68918371243be158031e9554fa
+DIST sphobjinv-2.2.tar.gz 1150648 BLAKE2B db29624c9e7c5ec014793bb76693dfbe87d8742a688b91c196bec12ac03852ae7999717588e075f58f5d2c3109b10d532bd117d482b540d30af27760869a5904 SHA512 257327ad168d5804639d3a064db683e0b9eb4f1dcb864a12a8ba440f3fde31c832bd72298f6381d2590bfac85ffe811563b8de124a135de2b6c1511217925103
diff --git a/dev-python/sphobjinv/sphobjinv-2.2.ebuild b/dev-python/sphobjinv/sphobjinv-2.2.ebuild
new file mode 100644
index 000000000000..d3097e5c313a
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-check[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+src_prepare() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+ sed -e '/CLI_TEST_TIMEOUT/s/2/20/' -i tests/test_cli.py || die
+
+ distutils-r1_src_prepare
+}