summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 10:32:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:04 +0100
commit5f5195f63ed51b9d1cf6bf1fef9fba2e1d61ec7d (patch)
tree94f6593a8bddc49574b19832d9980e88b6abcb4f /dev-python/sphobjinv
parentdev-python/setuptools: Bump to 60.8.0 (diff)
downloadgentoo-5f5195f63ed51b9d1cf6bf1fef9fba2e1d61ec7d.tar.gz
gentoo-5f5195f63ed51b9d1cf6bf1fef9fba2e1d61ec7d.tar.bz2
gentoo-5f5195f63ed51b9d1cf6bf1fef9fba2e1d61ec7d.zip
dev-python/sphobjinv: Bump to 2.2.1, unbundle deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphobjinv')
-rw-r--r--dev-python/sphobjinv/Manifest1
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.2.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
index 0681c1bf6e6e..87dca51a85a8 100644
--- a/dev-python/sphobjinv/Manifest
+++ b/dev-python/sphobjinv/Manifest
@@ -1,2 +1,3 @@
DIST sphobjinv-2.1.tar.gz 1144017 BLAKE2B 71878e1bac5202ab74298b56cd6172236ea524050323e0d6b8bbc0c89f1937d75f10d40b4071cfbe8c9031641e9a0ecb283da908c40840a61c12a7c892438241 SHA512 cde77d73b09b72358b0ac5b0d8f1a748e78dce6664d1b849ba68f5ff70dc43cbcff4581374d0151be29c4d97efe2920c5c00ff68918371243be158031e9554fa
+DIST sphobjinv-2.2.1.tar.gz 1150428 BLAKE2B 13bec53b00d14466aad652fb822ba32156d4ee3141f2df5bf55eaf77d03627c98c48dd142757ac43fe7dbf00716a85ee4c03060dfcf89e1d9aca4cd2589df5b0 SHA512 9247fc38e5d49adab0921f31e4ad1a8b2ca260c7a921b5fb9db7f800ee484335449031b0f51f81149ff71edba6cc93ab14a683ff6cdce2494322d05474e9a2c7
DIST sphobjinv-2.2.tar.gz 1150648 BLAKE2B db29624c9e7c5ec014793bb76693dfbe87d8742a688b91c196bec12ac03852ae7999717588e075f58f5d2c3109b10d532bd117d482b540d30af27760869a5904 SHA512 257327ad168d5804639d3a064db683e0b9eb4f1dcb864a12a8ba440f3fde31c832bd72298f6381d2590bfac85ffe811563b8de124a135de2b6c1511217925103
diff --git a/dev-python/sphobjinv/sphobjinv-2.2.1.ebuild b/dev-python/sphobjinv/sphobjinv-2.2.1.ebuild
new file mode 100644
index 000000000000..a9addc63712f
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/fuzzywuzzy[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-check[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-issues \
+ dev-python/sphinxcontrib-programoutput
+
+src_prepare() {
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+ sed -e '/CLI_TEST_TIMEOUT/s/2/20/' -i tests/test_cli.py || die
+
+ # remove bundled deps
+ rm -r src/sphobjinv/_vendored || die
+ sed -i -e 's:sphobjinv[.]_vendored[.]::' src/sphobjinv/*.py || die
+
+ distutils-r1_src_prepare
+}