summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 11:48:18 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 11:48:18 +0100
commit74b08e2d8765e3eed20bfa11440af6602e9eea42 (patch)
tree59da2cf406a6d4c5772cce94c5f9fcb42e5a4fd3 /dev-python/spyder-notebook
parentdev-python/spyder-vim: remove last-rited spyder plugin (diff)
downloadgentoo-74b08e2d8765e3eed20bfa11440af6602e9eea42.tar.gz
gentoo-74b08e2d8765e3eed20bfa11440af6602e9eea42.tar.bz2
gentoo-74b08e2d8765e3eed20bfa11440af6602e9eea42.zip
dev-python/spyder-notebook: remove last-rited spyder plugin
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest2
-rw-r--r--dev-python/spyder-notebook/metadata.xml12
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.3.2-r2.ebuild51
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
deleted file mode 100644
index d9d78015105b..000000000000
--- a/dev-python/spyder-notebook/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST spyder-notebook-0.3.2-spyder-5.patch 38116 BLAKE2B 2f311e179d1e0cbdf458773eb0e8d71f1f7cb9dbeca9f01b3dd12120f12177b2bb84ac6e09d7a17a9b26d667523bd28027f80102ff90889d6c781f7b530f8c95 SHA512 e57bc9d9b85622a64d151931d5b96a0c8d448075535ea9e91dfde5326c5192b3cd2d96c9fc88fef95237d4ec833e47238ddc3a3d12de25b4a8dcbda65c92e57f
-DIST spyder-notebook-0.3.2.tar.gz 3868854 BLAKE2B ca13e905dcc02d6767002481fb68ab8bc119d4d2511a1b881f033b9387d4237a1b2232ba75368f48b4d096998da40a14d862f125c0b01c6b2498165acebf4835 SHA512 dd3b505c8a678a9f49b1fce1d22a8a1a6cf334b65d1ab94852a7ba2120f53e2e38eb2fa0d58343588d7304511d7171d8e0040e10cda905db11ab65cae7f6ce5c
diff --git a/dev-python/spyder-notebook/metadata.xml b/dev-python/spyder-notebook/metadata.xml
deleted file mode 100644
index 32373b5ff3a3..000000000000
--- a/dev-python/spyder-notebook/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>andrewammerlaan@gentoo.org</email>
- <name>Andrew Ammerlaan</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">spyder-notebook</remote-id>
- </upstream>
- <stabilize-allarches/>
-</pkgmetadata>
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.3.2-r2.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.3.2-r2.ebuild
deleted file mode 100644
index e62f67cf8633..000000000000
--- a/dev-python/spyder-notebook/spyder-notebook-0.3.2-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Jupyter notebook integration with Spyder"
-HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~andrewammerlaan/${P}-spyder-5.patch"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/qdarkstyle[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/spyder-5.0[${PYTHON_USEDEP}]
- <dev-python/spyder-5.1[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
-"
-
-BDEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
-
-PATCHES=(
- "${DISTDIR}/${P}-spyder-5.patch"
-)
-
-# Tests do not work inside virtx/emerge for some reason, core dumped
-RESTRICT="test"
-distutils_enable_tests pytest
-
-python_test() {
- virtx pytest -vv
-}