summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-21 12:31:20 +0200
committerMatt Turner <mattst88@gentoo.org>2020-05-26 13:41:49 -0700
commitc004c4e23f56f1a62b3ed5e11484e789c1e65af1 (patch)
treeeb90fb720bbc5f707b5df92f8bea36550b6ddbd4 /dev-python/spyder-unittest
parentdev-python/spyder-notebook: drop py3_6 (diff)
downloadgentoo-c004c4e23f56f1a62b3ed5e11484e789c1e65af1.tar.gz
gentoo-c004c4e23f56f1a62b3ed5e11484e789c1e65af1.tar.bz2
gentoo-c004c4e23f56f1a62b3ed5e11484e789c1e65af1.zip
dev-python/spyder-unittest: version bump and drop py3_6
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest')
-rw-r--r--dev-python/spyder-unittest/Manifest1
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild2
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild38
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/spyder-unittest/Manifest b/dev-python/spyder-unittest/Manifest
index f00c3c77ddda..eb9c481d3275 100644
--- a/dev-python/spyder-unittest/Manifest
+++ b/dev-python/spyder-unittest/Manifest
@@ -1 +1,2 @@
DIST spyder-unittest-0.4.0.tar.gz 74408 BLAKE2B d1d8d3b331fefda5c918deb811052518109592919bce07006b49a533f85bc82e8a6efcb0eb4c9b799ef736eb1a5744bd637fdc1bf4f123b0ad5d742ca9c41027 SHA512 fe402b19bb7c2350cd27d1b5786840ed10736db042ee0b630d29a78aaee1e6cdfb3588eb8bd9bf9e124fdcaaab253e0c67e75480d26f41a16f678a7176db53d0
+DIST spyder-unittest-0.4.1.tar.gz 79158 BLAKE2B 10b7a8fde9dffdb436c44f22d305ceab84970dabd19aaeb7b5685be21f0e7bfc701a5fbbf9e393a71c9feb36dd6a2be68680e276c8d0841b2133a7171c504e3f SHA512 17e08b09accd938bf533c409f9a8011e9780f9cc4533af0ec754b6a01061490f198213cb77af9050e1e67e2b4b9c25251bbab27dce23d3f6e09f502cfbef95fc
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild
index e13f6bbc8f2f..5a999c55cae6 100644
--- a/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_7 )
inherit distutils-r1 virtualx
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
new file mode 100644
index 000000000000..5a999c55cae6
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ spyder_unittest_test() {
+ # fails to test in ${BUILDIR}/lib
+ # test do work if executed directly in the extracted tarball
+ local PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv spyder_unittest/tests spyder_unittest/widgets/tests
+ }
+
+ virtx spyder_unittest_test
+}