summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-02 13:26:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-02 13:49:18 +0200
commit1e9f01bf1d97ba8a52a2d90ddccfe108787e1c92 (patch)
treededde7bf1f3384838f338048750b7747412dd646 /dev-python/spyder
parentmedia-sound/strawberry: Removed old (diff)
downloadgentoo-1e9f01bf1d97ba8a52a2d90ddccfe108787e1c92.tar.gz
gentoo-1e9f01bf1d97ba8a52a2d90ddccfe108787e1c92.tar.bz2
gentoo-1e9f01bf1d97ba8a52a2d90ddccfe108787e1c92.zip
dev-python/spyder: allow parso 0.7.1
Otherwise we get stuck in a dependency conflict with python_targets_python3_10 Closes: https://bugs.gentoo.org/743466 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/spyder-5.0.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/spyder/spyder-5.0.5.ebuild b/dev-python/spyder/spyder-5.0.5.ebuild
index eb12c15ca98a..27d30b0d5a4c 100644
--- a/dev-python/spyder/spyder-5.0.5.ebuild
+++ b/dev-python/spyder/spyder-5.0.5.ebuild
@@ -46,7 +46,8 @@ RDEPEND="
>=dev-python/keyring-17.0.0[${PYTHON_USEDEP}]
>=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
>=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
- ~dev-python/parso-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/parso-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/parso-0.8.0[${PYTHON_USEDEP}]
>=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
>=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
>=dev-python/psutil-5.3[${PYTHON_USEDEP}]
@@ -145,6 +146,7 @@ python_prepare_all() {
# The original hasn't been update in over 6 months, and spyder upstream is slow
# in making the switch. Because we are running into issues with outdated deps
# and a whole dependency mess as a result, we can no longer wait for upstream.
+ # Also relax the parso dependency to allow parso 0.7.1
find . -name "*.py" -exec sed -i \
-e 's/python-language-server\[all\]>=0.36.2,<1.0.0/python-lsp-server\[all\]>=1.0.0/g' \
-e 's/python-language-server/python-lsp-server/g' \
@@ -158,6 +160,8 @@ python_prepare_all() {
-e 's/pylsp-black/python-lsp-black/g' \
-e 's/>=0.3.2;<0.4.0/>=0.4.0/g' \
-e 's/>=0.36.2;<1.0.0/>=1.0.0/g' \
+ -e "s/'parso==0.7.0'/'parso>=0.7.0,<0.8.0'/g" \
+ -e "s/'=0.7.0'/'>=0.7.0;<0.8.0'/g" \
{} + || die
# do not depend on pyqt5<13