summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-03 13:13:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-04 20:55:02 +0200
commit21299619ce7b4acc89c94d4da25f3ecf12124b8e (patch)
tree81283e968bb2f0dd5b448ed3ffbf90f28ca06d7e /dev-python/spyder
parentdev-python/dkimpy: Drop superfluous optfeature header (diff)
downloadgentoo-21299619ce7b4acc89c94d4da25f3ecf12124b8e.tar.gz
gentoo-21299619ce7b4acc89c94d4da25f3ecf12124b8e.tar.bz2
gentoo-21299619ce7b4acc89c94d4da25f3ecf12124b8e.zip
dev-python/spyder: Drop superfluous optfeature header
Fix indendation. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/spyder-4.2.0.ebuild39
-rw-r--r--dev-python/spyder/spyder-4.2.3.ebuild41
-rw-r--r--dev-python/spyder/spyder-4.2.5.ebuild41
3 files changed, 57 insertions, 64 deletions
diff --git a/dev-python/spyder/spyder-4.2.0.ebuild b/dev-python/spyder/spyder-4.2.0.ebuild
index 7a013fecdd6a..61c9697ed1a2 100644
--- a/dev-python/spyder/spyder-4.2.0.ebuild
+++ b/dev-python/spyder/spyder-4.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -197,23 +197,22 @@ python_test() {
pkg_postinst() {
xdg_pkg_postinst
- elog "To get additional features, optional runtime dependencies may be installed:"
- optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
- optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
- optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
- optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
- optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
- optfeature "Run Cython files in the IPython console" dev-python/cython
- optfeature "The hdf5/h5py plugin" dev-python/h5py
- optfeature "The line profiler plugin" dev-python/spyder-line-profiler
- optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
- # spyder-autopep8 does not have a release (yet)
- # and are not compatible with >=spyder-4.0.0 at the moment
- # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
- optfeature "Vim key bindings" dev-python/spyder-vim
- optfeature "Unittest support" dev-python/spyder-unittest
- optfeature "Jupyter notebook support" dev-python/spyder-notebook
- optfeature "System terminal inside spyder" dev-python/spyder-terminal
- # spyder-reports not yet updated to >=spyder-4.0.0
- # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+ optfeature "The hdf5/h5py plugin" dev-python/h5py
+ optfeature "The line profiler plugin" dev-python/spyder-line-profiler
+ optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
+ # spyder-autopep8 does not have a release (yet)
+ # and are not compatible with >=spyder-4.0.0 at the moment
+ # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
+ optfeature "Vim key bindings" dev-python/spyder-vim
+ optfeature "Unittest support" dev-python/spyder-unittest
+ optfeature "Jupyter notebook support" dev-python/spyder-notebook
+ optfeature "System terminal inside spyder" dev-python/spyder-terminal
+ # spyder-reports not yet updated to >=spyder-4.0.0
+ # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
}
diff --git a/dev-python/spyder/spyder-4.2.3.ebuild b/dev-python/spyder/spyder-4.2.3.ebuild
index 25d5e585b49f..5edd16889371 100644
--- a/dev-python/spyder/spyder-4.2.3.ebuild
+++ b/dev-python/spyder/spyder-4.2.3.ebuild
@@ -225,28 +225,25 @@ python_test() {
pkg_postinst() {
xdg_pkg_postinst
- elog "To get additional features, optional runtime dependencies may be installed:"
- optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
- optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
- optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
- optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
- optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
- optfeature "Run Cython files in the IPython console" dev-python/cython
- optfeature "The hdf5/h5py plugin" dev-python/h5py
- optfeature "The line profiler plugin" dev-python/spyder-line-profiler
- optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
- # spyder-autopep8 does not have a release (yet)
- # and are not compatible with >=spyder-4.0.0 at the moment
- # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
- optfeature "Vim key bindings" dev-python/spyder-vim
- optfeature "Unittest support" dev-python/spyder-unittest
- optfeature "Jupyter notebook support" dev-python/spyder-notebook
- optfeature "System terminal inside spyder" dev-python/spyder-terminal
- # spyder-reports not yet updated to >=spyder-4.0.0
- # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
-
- elog ""
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+ optfeature "The hdf5/h5py plugin" dev-python/h5py
+ optfeature "The line profiler plugin" dev-python/spyder-line-profiler
+ optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
+ # spyder-autopep8 does not have a release (yet)
+ # and are not compatible with >=spyder-4.0.0 at the moment
+ # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
+ optfeature "Vim key bindings" dev-python/spyder-vim
+ optfeature "Unittest support" dev-python/spyder-unittest
+ optfeature "Jupyter notebook support" dev-python/spyder-notebook
+ optfeature "System terminal inside spyder" dev-python/spyder-terminal
+ # spyder-reports not yet updated to >=spyder-4.0.0
+ # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
+ elog
elog "Spyder currently only works with PyQt5 as QtPy backend, PySide2 is not supported."
elog "Please ensure that 'eselect qtpy' is set to PyQt5."
- elog ""
}
diff --git a/dev-python/spyder/spyder-4.2.5.ebuild b/dev-python/spyder/spyder-4.2.5.ebuild
index 1ae8a57e1166..7bf44b9e866e 100644
--- a/dev-python/spyder/spyder-4.2.5.ebuild
+++ b/dev-python/spyder/spyder-4.2.5.ebuild
@@ -226,28 +226,25 @@ python_test() {
pkg_postinst() {
xdg_pkg_postinst
- elog "To get additional features, optional runtime dependencies may be installed:"
- optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
- optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
- optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
- optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
- optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
- optfeature "Run Cython files in the IPython console" dev-python/cython
- optfeature "The hdf5/h5py plugin" dev-python/h5py
- optfeature "The line profiler plugin" dev-python/spyder-line-profiler
- optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
- # spyder-autopep8 does not have a release (yet)
- # and are not compatible with >=spyder-4.0.0 at the moment
- # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
- optfeature "Vim key bindings" dev-python/spyder-vim
- optfeature "Unittest support" dev-python/spyder-unittest
- optfeature "Jupyter notebook support" dev-python/spyder-notebook
- optfeature "System terminal inside spyder" dev-python/spyder-terminal
- # spyder-reports not yet updated to >=spyder-4.0.0
- # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
-
- elog ""
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+ optfeature "The hdf5/h5py plugin" dev-python/h5py
+ optfeature "The line profiler plugin" dev-python/spyder-line-profiler
+ optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
+ # spyder-autopep8 does not have a release (yet)
+ # and are not compatible with >=spyder-4.0.0 at the moment
+ # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
+ optfeature "Vim key bindings" dev-python/spyder-vim
+ optfeature "Unittest support" dev-python/spyder-unittest
+ optfeature "Jupyter notebook support" dev-python/spyder-notebook
+ optfeature "System terminal inside spyder" dev-python/spyder-terminal
+ # spyder-reports not yet updated to >=spyder-4.0.0
+ # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
+ elog
elog "Spyder currently only works with PyQt5 as QtPy backend, PySide2 is not supported."
elog "Please ensure that 'eselect qtpy' is set to PyQt5."
- elog ""
}