summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-16 13:55:49 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:53 -0700
commit6e1b46695e785d92cae23d0679f7cd5e37639461 (patch)
tree156d6ae3d92df895775526d700a5cab32ba3cc87 /dev-python/spyder
parentdev-python/spyder-kernels: version bump (diff)
downloadgentoo-6e1b46695e785d92cae23d0679f7cd5e37639461.tar.gz
gentoo-6e1b46695e785d92cae23d0679f7cd5e37639461.tar.bz2
gentoo-6e1b46695e785d92cae23d0679f7cd5e37639461.zip
dev-python/spyder: version bump
Closes: https://bugs.gentoo.org/722508 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/Manifest2
-rw-r--r--dev-python/spyder/spyder-4.1.4.ebuild154
2 files changed, 156 insertions, 0 deletions
diff --git a/dev-python/spyder/Manifest b/dev-python/spyder/Manifest
index dce04209ea32..ee13c39ed1f1 100644
--- a/dev-python/spyder/Manifest
+++ b/dev-python/spyder/Manifest
@@ -1,2 +1,4 @@
DIST spyder-4.1.3.tar.gz 11610111 BLAKE2B 5cc25a6a8c6609dcec8e5e0d4beddfa582b2f632a4d1c61ef68e68e82f3cbc2b29694ddc7cdda216e4a8143254e6c1cca1e817a3f72be324671ff0196f3f0842 SHA512 0d0568c500c5b153bcd0073897eaf4e526e62bbc82c4a795683185cdac86f00c24d3b2efaa1f6bcd2f60305e387cda46bb732fbeaf21391e9d80ca4b18787b7e
+DIST spyder-4.1.4.tar.gz 11699453 BLAKE2B 208ba4f32fa548ef8478d72c046e70ba43a2fccd2040629af03f7f56c379ebefa1e90594054f15a92aebdd14307d001c68ee5e6d2401a841e408c4af42436c33 SHA512 8a5f63b11648002838e0b4e5427b1c7cf9cbe4a4fd20af7e33e5e789cddaf6393bb7200bfacf8c7af19d723f12d99d2e962a769706b806335f7146ddd6853735
+DIST spyder-docs-0d5afe26b8e28f3eb9f36f4ec3828bf8375c339e.tar.gz 29749238 BLAKE2B 9cf655c2a6fdf84278eaeb2e6f13c92eb4e585f213fd4f164a2707bc3cf8cb8abaaa213c5e781414fb0eecb3cf26b1f1708b394cd1ca12fa353ccbdd33f01dcb SHA512 8ed005cbfc32d7c68cf633790446d5d271f4d38ad190c09b2bcfd3ee96f24af5443d911bcdea90dc6ad94c5dab78437b9db02d0d4a7ceb9afa37a31e4bad24ae
DIST spyder-docs-6abac0ce8be017c6ecfb2b451700bf5b0e4c36dd.tar.gz 15821929 BLAKE2B 843510c87dc9ca616a6114159445894d2f4728201a93f424131f2524c8bc833d1b1540740d1e7cf473c4aed501cce775a073a9ee8748fe29b4193c927da70820 SHA512 c9161a7dc4bdef8e9a1ebe84ee7cc01fb9083965b54fc421d006a999ff753485c3d4a615e9646a6be47826663a64dc9af7f442dc2e4c81283c6eb5de55a8a3a9
diff --git a/dev-python/spyder/spyder-4.1.4.ebuild b/dev-python/spyder/spyder-4.1.4.ebuild
new file mode 100644
index 000000000000..184855914157
--- /dev/null
+++ b/dev-python/spyder/spyder-4.1.4.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit eutils xdg distutils-r1 virtualx
+
+# Commit of documentation to fetch
+DOCS_PV="0d5afe26b8e28f3eb9f36f4ec3828bf8375c339e"
+
+DESCRIPTION="The Scientific Python Development Environment"
+HOMEPAGE="
+ https://www.spyder-ide.org/
+ https://github.com/spyder-ide/spyder/
+ https://pypi.org/project/spyder/"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/spyder-ide/${PN}-docs/archive/${DOCS_PV}.tar.gz -> ${PN}-docs-${DOCS_PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Tests succeed, but freezes at the end, installation does not continue
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/atomicwrites-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cloudpickle-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/diff-match-patch-20181111[${PYTHON_USEDEP}]
+ dev-python/intervaltree[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4.0[${PYTHON_USEDEP}]
+ ~dev-python/jedi-0.17.1[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
+ ~dev-python/parso-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-language-server-0.34.0[${PYTHON_USEDEP}]
+ <dev-python/python-language-server-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.0.0[${PYTHON_USEDEP}]
+ >=dev-python/qdarkstyle-2.8[${PYTHON_USEDEP}]
+ >=dev-python/qtawesome-0.5.7[${PYTHON_USEDEP}]
+ >=dev-python/qtconsole-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.5.0[${PYTHON_USEDEP},svg,webengine]
+ >=dev-python/sphinx-0.6.6[${PYTHON_USEDEP}]
+ >=dev-python/spyder-kernels-1.9.2[${PYTHON_USEDEP}]
+ <dev-python/spyder-kernels-1.10.0[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/matplotlib[tk,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+)"
+
+# Based on the courtesy of Arfrever
+# This patch removes a call to update-desktop-database during build
+# This fails because access is denied to this command during build
+PATCHES=(
+ "${FILESDIR}/${PN}-4.1.2-build.patch"
+ "${FILESDIR}/${PN}-4.1.2-py3-only.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/doc --no-autodoc
+
+python_prepare_all() {
+ # move docs into workdir
+ mv ../spyder-docs-${DOCS_PV}* docs || die
+
+ # these deps are packaged separately
+ rm external-deps/* -r || die
+
+ # some tests still depend on QtPy[webkit] which is removed
+ # spyder itself works fine without webkit
+ rm spyder/widgets/tests/test_browser.py || die
+ rm spyder/plugins/onlinehelp/tests/test_pydocgui.py || die
+ rm spyder/plugins/ipythonconsole/tests/test_ipythonconsole.py || die
+ rm spyder/plugins/ipythonconsole/tests/test_ipython_config_dialog.py || die
+ rm spyder/plugins/help/tests/test_widgets.py || die
+ rm spyder/plugins/help/tests/test_plugin.py || die
+ # fails to collect
+ rm spyder/app/tests/test_mainwindow.py || die
+
+ # skip online test
+ rm spyder/widgets/github/tests/test_github_backend.py || die
+
+ # AssertionError: assert '' == 'This is some test text!'
+ sed -i -e 's:test_tab_copies_find_to_replace:_&:' \
+ spyder/plugins/editor/widgets/tests/test_editor.py || die
+
+ # RuntimeError: Unsafe load() call disabled by Gentoo. See bug #659348
+ sed -i -e 's:test_dependencies_for_binder_in_sync:_&:' \
+ spyder/tests/test_dependencies_in_sync.py || die
+
+ # Assertion error, can't connect/remember inside ebuild environment
+ rm spyder/plugins/ipythonconsole/widgets/tests/test_kernelconnect.py || die
+
+ # Assertion error (pytest-qt), maybe we can't do shortcuts inside ebuild environment?
+ sed -i -e 's:test_transform_to_uppercase_shortcut:_&:' \
+ -e 's:test_transform_to_lowercase_shortcut:_&:' \
+ -e 's:test_go_to_line_shortcut:_&:' \
+ -e 's:test_delete_line_shortcut:_&:' \
+ spyder/plugins/editor/widgets/tests/test_shortcuts.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx pytest -vv
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "To get additional features, optional runtime dependencies may be installed:"
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" sci-libs/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+ optfeature "The hdf5/h5py plugin" dev-python/h5py
+ optfeature "The line profiler plugin" dev-python/spyder-line-profiler
+ optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
+ # spyder-autopep8 does not have a release (yet)
+ # and are not compatible with >=spyder-4.0.0 at the moment
+ # optfeature "The autopep8 plugin" dev-python/spyder-autopep8
+ optfeature "Vim key bindings" dev-python/spyder-vim
+ optfeature "Unittest support" dev-python/spyder-unittest
+ optfeature "Jupyter notebook support" dev-python/spyder-notebook
+ optfeature "System terminal inside spyder" dev-python/spyder-terminal
+ # spyder-reports not yet updated to >=spyder-4.0.0
+ # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
+}