summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 20:17:49 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 20:21:00 +0100
commitb3c37a0bef68d76429b2789efee7b070ac24fbc7 (patch)
treee516b3ad5aa37009ac4f9764886caa73825d6ae9 /dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
parentprofiles: deprecate ia64 13.0 profiles (diff)
downloadgentoo-b3c37a0bef68d76429b2789efee7b070ac24fbc7.tar.gz
gentoo-b3c37a0bef68d76429b2789efee7b070ac24fbc7.tar.bz2
gentoo-b3c37a0bef68d76429b2789efee7b070ac24fbc7.zip
dev-python/sqlalchemy: Revert "Clean old up"
Revert the cleanup that accidentally broke some revdeps. Reverts: a45e42774e1b (dev-python/sqlalchemy: Clean old up)
Diffstat (limited to 'dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild b/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
new file mode 100644
index 000000000000..6681b0d832d0
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+# py3 appears underdone,
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils flag-o-matic
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="http://www.sqlalchemy.org/ https://pypi.python.org/pypi/SQLAlchemy"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples mssql mysql postgres +sqlite test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ mssql? ( dev-python/pymssql )
+ mysql? ( dev-python/mysql-python )
+ postgres? ( >=dev-python/psycopg-2 )
+ sqlite? (
+ >=dev-db/sqlite-3.3.13 )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-db/sqlite-3.3.13
+ >=dev-python/nose-0.10.4[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7-logging.handlers.patch" )
+
+python_prepare_all() {
+ # Disable tests hardcoding function call counts specific to Python versions.
+ rm -fr test/aaa_profiling
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ "${PYTHON}" sqla_nose.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ pushd doc > /dev/null
+ rm -fr build
+ dohtml -r [a-z]* _images _static
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}