summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-08 09:21:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-08 09:25:09 +0100
commit02f6c40b44bac39232f728e7bc3b7b67f3cba6a6 (patch)
tree4f60b8c0d5a1f9164b1a591abf480e73b1ccc9fe /dev-python/sqlparse/sqlparse-0.3.1.ebuild
parentdev-python/python-sqlparse: Remove redundant versions (diff)
downloadgentoo-02f6c40b44bac39232f728e7bc3b7b67f3cba6a6.tar.gz
gentoo-02f6c40b44bac39232f728e7bc3b7b67f3cba6a6.tar.bz2
gentoo-02f6c40b44bac39232f728e7bc3b7b67f3cba6a6.zip
Move dev-python/{python-sqlparse → sqlparse}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlparse/sqlparse-0.3.1.ebuild')
-rw-r--r--dev-python/sqlparse/sqlparse-0.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sqlparse/sqlparse-0.3.1.ebuild b/dev-python/sqlparse/sqlparse-0.3.1.ebuild
new file mode 100644
index 000000000000..d03098e3f4d8
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${P#python-}
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="doc"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest