summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-05-04 00:27:53 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-05-04 00:28:55 +0200
commit84d9dd1a124b27173f96ebb40c067deba1352da7 (patch)
tree28eb8bb3cf224113cefc2a66fc38b4bcd6655fbd /dev-python/ssh2-python
parentdev-util/src-cli: 3.27.0 bump (diff)
downloadgentoo-84d9dd1a124b27173f96ebb40c067deba1352da7.tar.gz
gentoo-84d9dd1a124b27173f96ebb40c067deba1352da7.tar.bz2
gentoo-84d9dd1a124b27173f96ebb40c067deba1352da7.zip
dev-python/ssh2-python: new package.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-python/ssh2-python')
-rw-r--r--dev-python/ssh2-python/Manifest1
-rw-r--r--dev-python/ssh2-python/metadata.xml12
-rw-r--r--dev-python/ssh2-python/ssh2-python-0.26.0.ebuild24
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ssh2-python/Manifest b/dev-python/ssh2-python/Manifest
new file mode 100644
index 000000000000..5a4bbd6fd4d0
--- /dev/null
+++ b/dev-python/ssh2-python/Manifest
@@ -0,0 +1 @@
+DIST ssh2-python-0.26.0.tar.gz 1147243 BLAKE2B 56ee98fa8694d6c9e0c163ec0200c96d8330172c0ae4612f40805ac26da02c7cf64fd4dd49841733c36ed7112c62baa036c901a9ef74a33a92a3d8dc66dc27cb SHA512 35f1a5486bc54bf2242d5b1d2fa24bd5365ffa864a8ae0f4a9f8d96f155ba0877e7dafdf87ea9988b146d8a36c203e44ca9a36a83a5060568bf798468e4a8116
diff --git a/dev-python/ssh2-python/metadata.xml b/dev-python/ssh2-python/metadata.xml
new file mode 100644
index 000000000000..e796b5cdc6d1
--- /dev/null
+++ b/dev-python/ssh2-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ParallelSSH/ssh2-python</remote-id>
+ <remote-id type="pypi">ssh2-python</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ssh2-python/ssh2-python-0.26.0.ebuild b/dev-python/ssh2-python/ssh2-python-0.26.0.ebuild
new file mode 100644
index 000000000000..c23977ec892d
--- /dev/null
+++ b/dev-python/ssh2-python/ssh2-python-0.26.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Super fast SSH2 protocol library, Python bindings for libssh2"
+HOMEPAGE="https://pypi.org/project/ssh2-python/"
+SRC_URI="https://github.com/ParallelSSH/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-libs/libssh2
+ dev-libs/openssl
+ sys-libs/zlib
+"
+python_configure_all() {
+ export SYSTEM_LIBSSH2=1
+}