summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ssl-fetch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ssl-fetch')
-rw-r--r--dev-python/ssl-fetch/Manifest3
-rw-r--r--dev-python/ssl-fetch/metadata.xml16
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild42
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.2.ebuild42
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.3.ebuild42
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-9999.ebuild46
6 files changed, 191 insertions, 0 deletions
diff --git a/dev-python/ssl-fetch/Manifest b/dev-python/ssl-fetch/Manifest
new file mode 100644
index 000000000000..cc4a9ac591af
--- /dev/null
+++ b/dev-python/ssl-fetch/Manifest
@@ -0,0 +1,3 @@
+DIST ssl-fetch-0.2.1.tar.gz 10703 SHA256 2905a8301477cf309484e3beef892d68b33910db71be45c08720f70791690b9d SHA512 ca4c4d29463d5761fbcea151f1229152bd0092418254ce614154b012af9a23c0c52bb733f64815499b5ae0ae9325a808ae2157e7ff707345e92352b672c98966 WHIRLPOOL 4bea8540fce0a2bcc0f8d55b4d87e7c544321b14967af95ded400f4ae0af3fd14c8390ed808352aa89c6ba7d267536d2ef8956dcba4b871226e2be9d4e71a2f8
+DIST ssl-fetch-0.2.tar.gz 10945 SHA256 027f63c5797e0fd84d4ed2195e42141316cceeed0b91058dd700b55482e40a78 SHA512 30aa040503eb05d8b0a7775ce843215ebbc198483fba2133e78a5da57f8b998c65018a1241f4f7bb3fbf66045c45bf050b59adb94a68c694aa3aeb6c0b5f726f WHIRLPOOL b4442b55d98741906eb1f3c0fda80cfbb0be42d2d8491c6bf1b86c0833a021ccfbae2887d2f833e9a297556d25c49cb4d617743a338e02299061f6e281d3563c
+DIST ssl-fetch-0.3.tar.gz 11283 SHA256 cee2f05899e729bba8942b26d17b0a97ddfb0a5d0beea4123bf7f2635db088e8 SHA512 82fddbccd3a5da73e81803ce252171d42428d88d301a772127071130ce4336742e46093359f0a996c679cd12ced02d09035af283d4d2f505c67a551283328756 WHIRLPOOL 49938e39c386a83e60caa0260643c31d2c180e93f3be59757dd17c1c9bc05338d5c580e997a96f698d4e1f4cf317bba9f6738044696c6949fcc1a5351e19f6c2
diff --git a/dev-python/ssl-fetch/metadata.xml b/dev-python/ssl-fetch/metadata.xml
new file mode 100644
index 000000000000..8d318a8ca736
--- /dev/null
+++ b/dev-python/ssl-fetch/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tools-portage</herd>
+ <maintainer>
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <maintainer>
+ <email>dastergon@gentoo.org</email>
+ <name>Pavlos Ratis</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dol-sen/ssl-fetch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild
new file mode 100644
index 000000000000..d60ff7ffdaab
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="https://github.com/dol-sen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is beta software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change in these early versions."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
+ einfo
+}
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.2.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.2.ebuild
new file mode 100644
index 000000000000..7daa072c4837
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="http://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is beta software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change in these early versions."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
+ einfo
+}
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild
new file mode 100644
index 000000000000..955698a7266b
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="http://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is beta software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change in these early versions."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the Freenode network"
+ einfo
+}
diff --git a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
new file mode 100644
index 000000000000..7fcd986339c8
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4} pypy)
+
+EGIT_BRANCH="master"
+
+inherit distutils-r1 git-2
+
+EGIT_REPO_URI="git://github.com/dol-sen/ssl-fetch.git"
+
+DESCRIPTION="A small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/ndg-httpsclient[python_targets_python2_7]
+ dev-python/pyasn1[python_targets_python2_7]
+ >=dev-python/pyopenssl-0.13[python_targets_python2_7]
+ )
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The APIs it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-portage, #gentoo-keys,... of the freenode network"
+ einfo
+}