summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-01 13:11:12 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-01 13:12:58 +0100
commit78b2e9b4c74ed07faba579401c1eda517133f20f (patch)
tree6676ad4356372d2e8bd9ad32d43ff77b059db042 /dev-python/statistics
parentdev-python/certifi: Version Bump (diff)
downloadgentoo-78b2e9b4c74ed07faba579401c1eda517133f20f.tar.gz
gentoo-78b2e9b4c74ed07faba579401c1eda517133f20f.tar.bz2
gentoo-78b2e9b4c74ed07faba579401c1eda517133f20f.zip
dev-python/statistics: New package, ebuild written by me
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/statistics')
-rw-r--r--dev-python/statistics/Manifest1
-rw-r--r--dev-python/statistics/metadata.xml12
-rw-r--r--dev-python/statistics/statistics-1.0.3.5.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/statistics/Manifest b/dev-python/statistics/Manifest
new file mode 100644
index 000000000000..63aa7070ab1f
--- /dev/null
+++ b/dev-python/statistics/Manifest
@@ -0,0 +1 @@
+DIST statistics-1.0.3.5.tar.gz 8303 SHA256 2dc379b80b07bf2ddd5488cad06b2b9531da4dd31edb04dc9ec0dc226486c138 SHA512 1d7fd2304a885dbd9ebc564323349f9c5ad1ea1ecea8182b52a1f42308963bd49f07c9dc9f0b87a35d2f6ed3c37429dbc38183c0b1bd65a527558e4504a9a3a0 WHIRLPOOL ce4b7309119da0eaa2a01678ce2b7e048fc895b82d31ec12e4b28371fa6c5e928537433d05afddc10a9f01434ba5be072bb52bd70fe7f724f12c55c25d85f852
diff --git a/dev-python/statistics/metadata.xml b/dev-python/statistics/metadata.xml
new file mode 100644
index 000000000000..48b92cdac472
--- /dev/null
+++ b/dev-python/statistics/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">statistics</remote-id>
+ <maintainer status="unknown">
+ <email>stefano@digitalemagine.com</email>
+ <name>Stefano Crosta</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/statistics/statistics-1.0.3.5.ebuild b/dev-python/statistics/statistics-1.0.3.5.ebuild
new file mode 100644
index 000000000000..a9d836ce770c
--- /dev/null
+++ b/dev-python/statistics/statistics-1.0.3.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python 2.* port of 3.4 Statistics Module"
+HOMEPAGE="https://github.com/digitalemagine/py-statistics http://pypi.python.org/pypi/statistics"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"