summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-01-08 11:12:10 -0500
committerTim Harder <radhermit@gentoo.org>2018-01-08 11:16:38 -0500
commitca6ff1d42e565471025e055e3c56b29f5393df47 (patch)
treecb3fae9d14cd905ffe0c22d93126df0e8c4cf454 /dev-python/statistics
parentdev-python/py-cpuinfo: use https for pypi homepage (diff)
downloadgentoo-ca6ff1d42e565471025e055e3c56b29f5393df47.tar.gz
gentoo-ca6ff1d42e565471025e055e3c56b29f5393df47.tar.bz2
gentoo-ca6ff1d42e565471025e055e3c56b29f5393df47.zip
dev-python/statistics: version bump to 3.4.0_beta3
Diffstat (limited to 'dev-python/statistics')
-rw-r--r--dev-python/statistics/Manifest1
-rw-r--r--dev-python/statistics/statistics-3.4.0_beta3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/statistics/Manifest b/dev-python/statistics/Manifest
index e32286d882e9..0e4af9db25cd 100644
--- a/dev-python/statistics/Manifest
+++ b/dev-python/statistics/Manifest
@@ -1 +1,2 @@
DIST statistics-1.0.3.5.tar.gz 8303 BLAKE2B bbefc6b9ea5fa00f2980072afced8810e9a33acba5ef07ffbaa6c6356a1dd66fe8062b98bf6d4273860d482aa352453395c16143220afca7050cee3546fad8ab SHA512 1d7fd2304a885dbd9ebc564323349f9c5ad1ea1ecea8182b52a1f42308963bd49f07c9dc9f0b87a35d2f6ed3c37429dbc38183c0b1bd65a527558e4504a9a3a0
+DIST statistics-3.4.0b3.tar.gz 12486 BLAKE2B d13c8fdba3a8788f1959a97fb3d11c53cdfa5d217751b0b1303d0be186e6f37a27ba5f641cf0cc90ecb96482527bdaa4b61778795a6c6a0fa19a93d881376d2a SHA512 d7bd7614fe3afe24e542eaebfedcd2147111ec567024e2533faaa379438c3f53138ce205c9b8fc71bed51bc13d5cb3d370b476f199a6250f4457adcba4be6522
diff --git a/dev-python/statistics/statistics-3.4.0_beta3.ebuild b/dev-python/statistics/statistics-3.4.0_beta3.ebuild
new file mode 100644
index 000000000000..01236be413e2
--- /dev/null
+++ b/dev-python/statistics/statistics-3.4.0_beta3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P=${PN}-${PV/_beta/b}
+
+DESCRIPTION="A Python 2.* port of 3.4 Statistics Module"
+HOMEPAGE="https://github.com/digitalemagine/py-statistics https://pypi.python.org/pypi/statistics"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}