summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 11:22:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 11:49:50 +0200
commit8f59c211dda95ef7b68141fbf4346b2b8251e1b8 (patch)
tree0188e65c201e2adfe212e34d863b3075c4448e63 /dev-python/stevedore/stevedore-1.28.0.ebuild
parentdev-python/stevedore: Stabilize 1.31.0 ALLARCHES (diff)
downloadgentoo-8f59c211dda95ef7b68141fbf4346b2b8251e1b8.tar.gz
gentoo-8f59c211dda95ef7b68141fbf4346b2b8251e1b8.tar.bz2
gentoo-8f59c211dda95ef7b68141fbf4346b2b8251e1b8.zip
dev-python/stevedore: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stevedore/stevedore-1.28.0.ebuild')
-rw-r--r--dev-python/stevedore/stevedore-1.28.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/stevedore/stevedore-1.28.0.ebuild b/dev-python/stevedore/stevedore-1.28.0.ebuild
deleted file mode 100644
index 6d88b3e42d5f..000000000000
--- a/dev-python/stevedore/stevedore-1.28.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests --verbosity=3 stevedore || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}