summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-13 10:45:49 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-13 10:45:49 -0500
commit2961a32774cd9e766ec631390993f3d97eb66c76 (patch)
tree15dc219f6cf1e1772312cdb3603f7b79ac7a8c69 /dev-python/stormpath/stormpath-2.4.4.ebuild
parentdev-python/monotonic: remove version 0.2 (diff)
downloadgentoo-2961a32774cd9e766ec631390993f3d97eb66c76.tar.gz
gentoo-2961a32774cd9e766ec631390993f3d97eb66c76.tar.bz2
gentoo-2961a32774cd9e766ec631390993f3d97eb66c76.zip
dev-python/stormpath: add version 2.4.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/stormpath/stormpath-2.4.4.ebuild')
-rw-r--r--dev-python/stormpath/stormpath-2.4.4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/stormpath/stormpath-2.4.4.ebuild b/dev-python/stormpath/stormpath-2.4.4.ebuild
new file mode 100644
index 000000000000..82cb332bb003
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.4.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ <=dev-python/oauthlib-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ esetup.py docs
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}