summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-11 13:07:26 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-11 13:07:26 -0500
commit85296281f69e35f59711e9c298cae20d022c4fba (patch)
tree26963031ab8b28400009a83833ccc2acee9c8d45 /dev-python/stormpath
parentdev-scheme/scm: Fix man page destination (bug #351389) (diff)
downloadgentoo-85296281f69e35f59711e9c298cae20d022c4fba.tar.gz
gentoo-85296281f69e35f59711e9c298cae20d022c4fba.tar.bz2
gentoo-85296281f69e35f59711e9c298cae20d022c4fba.zip
dev-python/stormpatch: add version 2.0.8
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/stormpath')
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/files/drop-test-module.patch13
-rw-r--r--dev-python/stormpath/metadata.xml10
-rw-r--r--dev-python/stormpath/stormpath-2.0.8.ebuild59
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
new file mode 100644
index 000000000000..9ad4b51c6a96
--- /dev/null
+++ b/dev-python/stormpath/Manifest
@@ -0,0 +1 @@
+DIST stormpath-2.0.8.tar.gz 4326469 SHA256 9f6ad7e7b210024915e2139b2ed395a7c0fff6ca49ad3cdf58dc8f214d080c70 SHA512 661714fac02528111bb01e30f8c16b1d8701fe894b21d803958331819ce145a9ec03864111b861286224b33aaf56ca68ddcef2b67cd0003c498cd007ce375a03 WHIRLPOOL 12e6f7ec559a654ab59d34106d85d98ada4c7e3dee6fcec6cad0a2500608e962289d73a50e6ce6d81122c43f0f53b30d861203c8a976ac7bdbdab1cd8f5db6be
diff --git a/dev-python/stormpath/files/drop-test-module.patch b/dev-python/stormpath/files/drop-test-module.patch
new file mode 100644
index 000000000000..fe99f0c882f3
--- /dev/null
+++ b/dev-python/stormpath/files/drop-test-module.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index f156b33..cc6f16a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -87,7 +87,7 @@ setup(
+ 'python-dateutil>=2.4.0',
+ 'pydispatcher>=2.0.5'
+ ],
+- packages = find_packages(exclude=['tests']),
++ packages = find_packages(exclude=['*.tests', '*.tests.*', 'tests.*', 'tests']),
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
diff --git a/dev-python/stormpath/metadata.xml b/dev-python/stormpath/metadata.xml
new file mode 100644
index 000000000000..02be8c5eb78f
--- /dev/null
+++ b/dev-python/stormpath/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/stormpath/stormpath-2.0.8.ebuild b/dev-python/stormpath/stormpath-2.0.8.ebuild
new file mode 100644
index 000000000000..131b6b7b36a0
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.0.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/drop-test-module.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test || die "tests failed under ${EPYTYHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}