summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-12-12 13:36:13 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-12-12 13:36:31 -0600
commit92394dfa5faea8be768a95483778e0b6563192f0 (patch)
tree1350c0413b47172c839343a2c4f7ad97ddef8801 /dev-python/stormpath
parentapp-shells/hstr: Version bump. (diff)
downloadgentoo-92394dfa5faea8be768a95483778e0b6563192f0.tar.gz
gentoo-92394dfa5faea8be768a95483778e0b6563192f0.tar.bz2
gentoo-92394dfa5faea8be768a95483778e0b6563192f0.zip
dev-python/stormpath: add version 2.1.6
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/stormpath')
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.1.6.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 6fc21b3d81d8..fd4257493b02 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1,3 +1,4 @@
DIST stormpath-2.1.2.tar.gz 4337164 SHA256 10f46c7ebb27274f61c4b550eb6fc58e54260fa0fb1f96a4b7fce530d789d11c SHA512 c3b3e93f4d5515df8e5ab94770c995a5e7912a53f58f05ca3a1f630c41fc0f76e39cf213dbfad8858d7bfe5f964f6d9cbfad9013de33e9a02e0484bd92a7957d WHIRLPOOL adfbf1cf071167a93989cd4d80039a4eb8c42a908075207a4db4db3a38c87e3b9470b9c1c02946e9481e52d875e836d0c77a72050de2a1f79fc78b5ed037dfe2
DIST stormpath-2.1.4.tar.gz 4338169 SHA256 adbc595b243861be0268c2c71061de8ce6dc8f9a92d7398f92bf77a734315b2f SHA512 6834f1b8db731872208c96b9acb2ff66e5d7fcbb6ae0c1f1de541ce1597a786834f2b68c43d00c5adcb1018749c53b45444dde2a81a520fed79fd9b6f0f07ab0 WHIRLPOOL 6f50a1f6476d4486f43da55ae48c56942ef90820db4434c3b567222cb65d56aaa5649249dfc10add807f5ccba245d99b89efa031201af61bc888b902cf66b4ea
DIST stormpath-2.1.5.tar.gz 4339093 SHA256 cea6810c5caa666c3a73ea0bbf14826687318aea2a82c51d93886679b786b94b SHA512 d373d36bd6dc647fcedad99722c6ff53447b4b11090ffbbf2e72a206d27e66804d7e756d0588b80b11110700297beebb894b4d5301df97a836a4204622ea83af WHIRLPOOL 14a580f934afc74f7f15b4ac897474bb00ab199470d94c671b3f39c625d460aa601329a18cf23b206f12ab2b0f9f25d5903c14f507f614e38953da47bdfc7a92
+DIST stormpath-2.1.6.tar.gz 4339678 SHA256 47649cf8edaf5ef48346f74558e62e0aaf28fb49bd7e3db99db9338739913d77 SHA512 2cc6ecd674ca6b5fcfbb6664f863cb4c6378748eb5ca2ceb5e0db3ac46c567a4b62a1bb595044b15c0294b5abe471c9ac675b93db49e5d2e146cd8954c8c7611 WHIRLPOOL c15085c2a1e5600ff93bc1e013439270c17472035a39fde52f31e21971b5508b4ff50a9a5f1472aa185282fefbfc9015a88eed0b5c641acf787abfaf9f72e06b
diff --git a/dev-python/stormpath/stormpath-2.1.6.ebuild b/dev-python/stormpath/stormpath-2.1.6.ebuild
new file mode 100644
index 000000000000..e6bdfe5b1541
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}