summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-19 01:46:56 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-19 01:47:16 +0000
commit49ed0a07471907652bb7faf49c6d87a49aaef9e3 (patch)
tree2f06fbae02c8493feb56f2a820a71a593b328458 /dev-python/sunpy/sunpy-0.8.0.ebuild
parentprofiles: mask USE=vde for app-emulation/qemu and net-vpn/tinc. (diff)
downloadgentoo-49ed0a07471907652bb7faf49c6d87a49aaef9e3.tar.gz
gentoo-49ed0a07471907652bb7faf49c6d87a49aaef9e3.tar.bz2
gentoo-49ed0a07471907652bb7faf49c6d87a49aaef9e3.zip
dev-python/sunpy: version bump
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/sunpy/sunpy-0.8.0.ebuild')
-rw-r--r--dev-python/sunpy/sunpy-0.8.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/sunpy/sunpy-0.8.0.ebuild b/dev-python/sunpy/sunpy-0.8.0.ebuild
new file mode 100644
index 000000000000..4aa502509e14
--- /dev/null
+++ b/dev-python/sunpy/sunpy-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Software library for solar physics based on Python"
+HOMEPAGE="http://sunpy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="jpeg2k test"
+
+RDEPEND="
+ >=dev-python/astropy-2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-libs/scikits_image[${PYTHON_USEDEP}]
+ jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mpl[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
+}