summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-31 14:14:08 +0000
committerSam James <sam@gentoo.org>2020-08-31 14:14:08 +0000
commitd00923053ed81dcf2acd3ee6245e74222ce542bb (patch)
tree250618647ae0e627bf4f91343d2aa0c688ccacff /dev-python/sympy
parentdev-python/theano: cleanup old (diff)
downloadgentoo-d00923053ed81dcf2acd3ee6245e74222ce542bb.tar.gz
gentoo-d00923053ed81dcf2acd3ee6245e74222ce542bb.tar.bz2
gentoo-d00923053ed81dcf2acd3ee6245e74222ce542bb.zip
dev-python/sympy: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/sympy-1.5.1-r1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index ef247c746c89..c69fce3ec46d 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,3 +1,2 @@
-DIST sympy-1.5.1.tar.gz 6815997 BLAKE2B bc74d01fdf2ccea6b83a06c11f810e3d105e9d35b397c8b87a1bcc4e316d00c456f576baf57d1b4a6175e056dec58f05fbb05893519775ffa252ac018452d2ff SHA512 3c4220243d2cbcff9eedb2a7986431b5b4d7d0007c78208a60b21830c9a3528d2171086874c42205c1227f779e44c19b9562943e2935d329bc352e7ea85396c7
DIST sympy-1.6.1.tar.gz 6811393 BLAKE2B cd19946fc726b5a74f9ff0af07f07f8f76ea28b20818653d785848e331c126d634d8167e3506d8b87c12ed057df4a59551f0a0214b7d1292e199c6a3353f70be SHA512 95630b6fad1e41f2d58d1f4f4433ef76d4553f3e119bfdd36048c5880ac7f07d572e901eaae0b5c6208f598989a86ab5e03932a851f8048c584154973be6982c
DIST sympy-1.6.2.tar.gz 6811705 BLAKE2B 4cd894d28bedc986acc8ef67aa60f82e0899c2ed028658a8f340d7538b890e0ed380b3614a464eb58d71873b29b0795508b4556bb8115bf0c108336ef1e4cca3 SHA512 e16a1d85aba438e4248bac48a163ea1827e2cee57c28f7670ed19cc69d4c08d6796d62f79d245e269d75765b8f7ff4f4ca2841f98534e136ceeb5d3f7a5d252a
diff --git a/dev-python/sympy/sympy-1.5.1-r1.ebuild b/dev-python/sympy/sympy-1.5.1-r1.ebuild
deleted file mode 100644
index f5455d9408f1..000000000000
--- a/dev-python/sympy/sympy-1.5.1-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1 eutils virtualx
-
-DESCRIPTION="Computer Algebra System in pure Python"
-HOMEPAGE="https://sympy.org"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="test"
-# All tests actually pass, except a bunch of tests related to the deprecated pygletplot
-# It is a non-trivial work to wipe out all such tests :-(
-
-RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
- ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
- latex? (
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- png? ( app-text/dvipng )
- pdf? ( app-text/ghostscript-gpl )
- )
- mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
- opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
- symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
- texmacs? ( app-office/texmacs )
- theano? ( dev-python/theano[${PYTHON_USEDEP}] )
-"
-
-DEPEND="${RDEPEND}
- test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${PN}-${P}"
-
-python_test() {
- virtx "${PYTHON}" setup.py test
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-
- if use texmacs; then
- exeinto /usr/libexec/TeXmacs/bin/
- doexe data/TeXmacs/bin/tm_sympy
- insinto /usr/share/TeXmacs/plugins/sympy/
- doins -r data/TeXmacs/progs
- fi
-}